omniauth-saml has dependency on ruby-saml version with Signature Wrapping Attack issue
Key facts
- Attack vector
- —
- Privileges required
- —
- User interaction
- —
- Attack complexity
- —
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- —
- Fix status
- Fixed
No CVSS vector from any source. Fix status from GitHub. Impact type from CWE-347.
Summary
### Summary There are 2 new Critical Signature Wrapping Vulnerabilities (CVE-2025-25292, CVE-2025-25291) and a potential DDOS Moderated Vulneratiblity (CVE-2025-25293) affecting ruby-saml, a dependency of omniauth-saml. The fix will be applied to ruby-saml and released 12 March 2025, under version 1.18.0. Please [upgrade](https://github.com/omniauth/omniauth-saml/blob/master/omniauth-saml.gemspec#L16) the ruby-saml requirement to v1.18.0. ### Impact Signature Wrapping Vulnerabilities allows an attacker to impersonate a user.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | omniauth-saml (RubyGems) | 2.2.0 to before 2.2.3 | 2.2.3 | Patch available | GHSA-hw46-3hmr-x9xv |
| — | omniauth-saml (RubyGems) | 2.0.0 to before 2.1.3 | 2.1.3 | Patch available | GHSA-hw46-3hmr-x9xv |
| — | omniauth-saml (RubyGems) | before 1.10.6 | 1.10.6 | Patch available | GHSA-hw46-3hmr-x9xv |
- omniauth-saml (RubyGems) Vendor— Affected 2.2.0 to before 2.2.3 Fixed in 2.2.3 Patch available GHSA-hw46-3hmr-x9xv
- omniauth-saml (RubyGems) Vendor— Affected 2.0.0 to before 2.1.3 Fixed in 2.1.3 Patch available GHSA-hw46-3hmr-x9xv
- omniauth-saml (RubyGems) Vendor— Affected before 1.10.6 Fixed in 1.10.6 Patch available GHSA-hw46-3hmr-x9xv
Remediation
- Fix · GHSA-hw46-3hmr-x9xv omniauth-saml (RubyGems) Fixed in 2.2.3 Advisory →
- Fix · GHSA-hw46-3hmr-x9xv omniauth-saml (RubyGems) Fixed in 2.1.3 Advisory →
- Fix · GHSA-hw46-3hmr-x9xv omniauth-saml (RubyGems) Fixed in 1.10.6 Advisory →
Timeline
- 2026-10-03 Threatist record created from GHSA-hw46-3hmr-x9xv
References
Other 8
- https://github.com/omniauth/omniauth-saml/security/advisories/GHSA-hw46-3hmr-x9xv
- https://github.com/omniauth/omniauth-saml/commit/0d5eaa0d808acb2ac96deadf5c750ac1cf2d92b5
- https://github.com/omniauth/omniauth-saml/commit/2c8a482801808bbcb0188214bde74680b8018a35
- https://github.com/omniauth/omniauth-saml/commit/7a348b49083462a566af41a5ae85e9f3af15b985
- https://github.com/omniauth/omniauth-saml
- https://github.com/omniauth/omniauth-saml/blob/master/omniauth-saml.gemspec#L16
- https://github.com/rubysec/ruby-advisory-db/blob/master/gems/omniauth-saml/GHSA-hw46-3hmr-x9xv.yml
- https://rubygems.org/gems/omniauth-saml/versions/2.2.3
Sources
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences