Read the docs
TI-2025-43615 Aliases GHSA-w466-2wfc-8g58

Open WebUI has vulnerable dependency on starlette via fastapi

Priority LOW 38CWE-400Published · Updated

Key facts

Attack vector
—
Privileges required
—
User interaction
—
Attack complexity
—
Impact type
Denial of service
Confidentiality · integrity · availability
—
Fix status
Fixed

No CVSS vector from any source. Fix status from GitHub. Impact type from CWE-400.

Summary

In version 0.3.32 of open-webui, the application uses a vulnerable version of the starlette package through its dependency on fastapi. The starlette package versions <=0.49 are susceptible to uncontrolled resource consumption, which can be exploited to cause a denial of service through memory exhaustion. This issue is addressed in fastapi version 0.115.3.

Why it matters now

Fix Fixed open-webui (PyPI): 0.5.8

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
—open-webui (PyPI)before 0.5.80.5.8Patch availableGHSA-w466-2wfc-8g58
  • open-webui (PyPI) Vendor— Affected before 0.5.8 Fixed in 0.5.8 Patch available GHSA-w466-2wfc-8g58

Remediation

  • Fix · GHSA-w466-2wfc-8g58 open-webui (PyPI) Fixed in 0.5.8 Advisory →

Timeline

  1. 2026-10-03 Threatist record created from GHSA-w466-2wfc-8g58

References

Sources

This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences