Read the docs
TI-2025-43635 Aliases GHSA-5pm7-cp8f-p2c2

wallabag/wallabag Has Multiple Cross-Site Request Forgery (CSRF) Vulnerabilities

Priority LOW 38CWE-352Published · Updated

Key facts

Attack vector
—
Privileges required
—
User interaction
—
Attack complexity
—
Impact type
Tampering
Confidentiality · integrity · availability
—
Fix status
Fixed

No CVSS vector from any source. Fix status from GitHub. Impact type from CWE-352.

Summary

## Impact wallabag versions prior to 2.6.11 were discovered to contain multiple Cross-Site Request Forgery (CSRF) vulnerabilities across several endpoints. An attacker could craft a malicious link or page that, if visited by a logged-in wallabag user, could trick the user's browser into performing unintended actions within their wallabag account without their consent. Additionally, one endpoint affects the login page locale setting. The affected endpoints allow attackers to potentially perform actions such as: * **Manage API Tokens:** * `/generate-token` * `/revoke-token` * **Manage User Rules:** * `/tagging-rule/delete/{taggingRule}` * `/ignore-origin-user-rule/delete/{ignoreOriginUserRule}` * **Modify User Configuration:** * `/config/view-mode` * **Manage Individual Entries:** * `/reload/{id}` * `/archive/{id}` * `/star/{id}` * `/delete/{id}` * `/share/{id}` * `/share/delete/{id}` * **Manage Tags:** * `/remove-tag/{entry}/{tag}` * `/tag/search/{filter}` * `/tag/delete/{slug}` * **Perform Bulk Actions:** * `/mass` * **Change Interface Language (Login Page):** * `/locale/{language}` Successfully exploiting these vulnerabilities could lead to unauthorized modification or deletion of user data, configuration changes, token manipulation, or interface changes, depending on the specific endpoint targeted. This set of vulnerabilities has an aggregated CVSS v3.1 score of 4.3 (Medium). **Users are strongly advised to upgrade their wallabag instance to version 2.6.11 or later to mitigate these vulnerabilities.** ## Resolution These vulnerabilities have been addressed in wallabag version **2.6.11**. The affected endpoints have been modified to require the HTTP POST method along with a valid CSRF token for state-changing actions, preventing attackers from forcing users' browsers to perform these actions unintentionally. ## Credits Found, reported and fixed by @yguedidi

Why it matters now

Fix Fixed wallabag/wallabag (Packagist): 2.6.11

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
—wallabag/wallabag (Packagist)before 2.6.112.6.11Patch availableGHSA-5pm7-cp8f-p2c2
  • wallabag/wallabag (Packagist) Vendor— Affected before 2.6.11 Fixed in 2.6.11 Patch available GHSA-5pm7-cp8f-p2c2

Remediation

  • Fix · GHSA-5pm7-cp8f-p2c2 wallabag/wallabag (Packagist) Fixed in 2.6.11 Advisory →

Timeline

  1. 2026-10-03 Threatist record created from GHSA-5pm7-cp8f-p2c2

References

Other 20

Sources

This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences