@account-kit/smart-contracts Allowlist Module Bypass Vulnerability
Priority LOW 38CWE-288Published · Updated
Key facts
- Attack vector
- —
- Privileges required
- —
- User interaction
- —
- Attack complexity
- —
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- —
- Fix status
- Fixed
No CVSS vector from any source. Fix status from GitHub. Impact type from CWE-288.
Summary
### Summary Allowlist module contains a bypass vulnerability ### Details The logic for using an allowlist on a Modular Account V2 contained a bug that allowed session keys to bypass any allowlist configuration ### Action If you are using @aa-sdk and/or @account-kit/smart-contracts between the versions of >=4.8.0 and <4.28.1, please upgrade to 4.28.2
Why it matters now
Fix Fixed @account-kit/smart-contracts (npm): 4.28.2
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | @account-kit/smart-contracts (npm) | 4.8.0 to before 4.28.2 | 4.28.2 | Patch available | GHSA-wfm2-rq5g-f8v5 |
- @account-kit/smart-contracts (npm) Vendor— Affected 4.8.0 to before 4.28.2 Fixed in 4.28.2 Patch available GHSA-wfm2-rq5g-f8v5
Remediation
- Fix · GHSA-wfm2-rq5g-f8v5 @account-kit/smart-contracts (npm) Fixed in 4.28.2 Advisory →
Timeline
- 2026-10-03 Threatist record created from GHSA-wfm2-rq5g-f8v5
References
Sources
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences