Read the docs
TI-2025-43669 Aliases GHSA-9wg9-93h9-j8ch

Auth0 Symfony SDK Vulnerable to Brute Force Authentication Tags of CookieStore Sessions

Priority LOW 38CWE-287Published · Updated

Key facts

Attack vector
—
Privileges required
—
User interaction
—
Attack complexity
—
Impact type
Security bypass
Confidentiality · integrity · availability
—
Fix status
Fixed

No CVSS vector from any source. Fix status from GitHub. Impact type from CWE-287.

Summary

**Overview** Session cookies of applications using the Auth0 symfony SDK configured with CookieStore have authentication tags that can be brute forced, which may result in unauthorized access. **Am I Affected?** You are affected by this vulnerability if you meet the following pre-conditions: 1. Applications using the Auth0 symfony SDK with version <=5.3.1 2. Auth0/Symfony SDK uses the Auth0-PHP SDK with version 8.0.0-BETA1 or higher and below 8.14.0. 3. Session storage configured with CookieStore. **Fix** Upgrade Auth0/symfony to v5.4.0. As an additional precautionary measure, we recommend rotating your cookie encryption keys. Note that once updated, any previous session cookies will be rejected. **Acknowledgement** Okta would like to thank Félix Charette for discovering this vulnerability.

Why it matters now

Fix Fixed auth0/symfony (Packagist): 5.4.0

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
—auth0/symfony (Packagist)before 5.4.05.4.0Patch availableGHSA-9wg9-93h9-j8ch
  • auth0/symfony (Packagist) Vendor— Affected before 5.4.0 Fixed in 5.4.0 Patch available GHSA-9wg9-93h9-j8ch

Remediation

  • Fix · GHSA-9wg9-93h9-j8ch auth0/symfony (Packagist) Fixed in 5.4.0 Advisory →

Timeline

  1. 2026-10-03 Threatist record created from GHSA-9wg9-93h9-j8ch

References

Sources

This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences