Auth0 Wordpress plugin Vulnerable to Brute Force Authentication Tags of CookieStore Sessions
Key facts
- Attack vector
- —
- Privileges required
- —
- User interaction
- —
- Attack complexity
- —
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- —
- Fix status
- Fixed
No CVSS vector from any source. Fix status from GitHub. Impact type from CWE-287.
Summary
**Overview** Session cookies of applications using the Auth0 Wordpress plugin configured with CookieStore have authentication tags that can be brute forced, which may result in unauthorized access. **Am I Affected?** You are affected by this vulnerability if you meet the following pre-conditions: 1. Applications using the Auth0 WordPress Plugin with version <=5.2.1 2. Auth0 WordPress Plugin uses the Auth0-PHP SDK with version 8.0.0-BETA1 or higher and below 8.14.0. 3. Session storage configured with CookieStore. **Fix** Upgrade Auth0/wordpress plugin to v5.3.0. As an additional precautionary measure, we recommend rotating your cookie encryption keys. Note that once updated, any previous session cookies will be rejected. **Acknowledgement** Okta would like to thank Félix Charette for discovering this vulnerability.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | auth0/wordpress (Packagist) | before 5.3.0 | 5.3.0 | Patch available | GHSA-2f4r-34m4-3w8q |
- auth0/wordpress (Packagist) Vendor— Affected before 5.3.0 Fixed in 5.3.0 Patch available GHSA-2f4r-34m4-3w8q
Remediation
- Fix · GHSA-2f4r-34m4-3w8q auth0/wordpress (Packagist) Fixed in 5.3.0 Advisory →
Timeline
- 2026-10-03 Threatist record created from GHSA-2f4r-34m4-3w8q
References
Sources
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences