laravel-auth0 SDK Vulnerable to Brute Force Authentication Tags of CookieStore Sessions
Key facts
- Attack vector
- —
- Privileges required
- —
- User interaction
- —
- Attack complexity
- —
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- —
- Fix status
- Fixed
No CVSS vector from any source. Fix status from GitHub. Impact type from CWE-287.
Summary
**Overview** Session cookies of applications using the laravel-auth0 SDK configured with CookieStore have authentication tags that can be brute forced, which may result in unauthorized access. **Am I Affected?** You are affected by this vulnerability if you meet the following pre-conditions: 1. Applications using laravel-auth0 SDK with version <=7.16.0 2. laravel-auth0 SDK uses the Auth0-PHP SDK with version 8.0.0-BETA1 or higher and below 8.14.0. 3. Session storage configured with CookieStore. **Fix** Upgrade Auth0/laravel-auth0 to v7.17.0. As an additional precautionary measure, we recommend rotating your cookie encryption keys. Note that once updated, any previous session cookies will be rejected. **Acknowledgement** Okta would like to thank Félix Charette for discovering this vulnerability.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | auth0/login (Packagist) | before 7.17.0 | 7.17.0 | Patch available | GHSA-9fwj-9mjf-rhj3 |
- auth0/login (Packagist) Vendor— Affected before 7.17.0 Fixed in 7.17.0 Patch available GHSA-9fwj-9mjf-rhj3
Remediation
- Fix · GHSA-9fwj-9mjf-rhj3 auth0/login (Packagist) Fixed in 7.17.0 Advisory →
Timeline
- 2026-10-03 Threatist record created from GHSA-9fwj-9mjf-rhj3
References
Sources
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences