mitmproxy binaries embed a vulnerable python-hyper/h2 dependency
Key facts
- Attack vector
- —
- Privileges required
- —
- User interaction
- —
- Attack complexity
- —
- Impact type
- —
- Confidentiality · integrity · availability
- —
- Fix status
- Fixed
No CVSS vector from any source. Fix status from GitHub.
Summary
mitmproxy 12.1.1 and below embed python-hyper/h2 ≤ v4.2.0, which has a gap in its HTTP/2 header validation. This enables request smuggling attacks when mitmproxy is in a configuration where it translates HTTP/2 to HTTP/1. For example, this affects reverse proxies to `http://` backends. It does not affect mitmproxy's regular mode. All users are encouraged to upgrade to mitmproxy 12.1.2, which includes a fixed version of h2. More details about the vulnerability itself can be found at https://github.com/python-hyper/h2/security/advisories/GHSA-847f-9342-265h.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | mitmproxy (PyPI) | before 12.1.2 | 12.1.2 | Patch available | GHSA-63cx-g855-hvv4 |
- mitmproxy (PyPI) Vendor— Affected before 12.1.2 Fixed in 12.1.2 Patch available GHSA-63cx-g855-hvv4
Remediation
- Fix · GHSA-63cx-g855-hvv4 mitmproxy (PyPI) Fixed in 12.1.2 Advisory →
Timeline
- 2026-10-03 Threatist record created from GHSA-63cx-g855-hvv4
References
Sources
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences