Read the docs
TI-2025-43766 Aliases GHSA-qj3p-xc97-xw74

MetaMask SDK indirectly exposed via malicious [email protected] dependency

Priority LOW 38CWE-506Published · Updated

Key facts

Attack vector
—
Privileges required
—
User interaction
—
Attack complexity
—
Impact type
Code execution
Confidentiality · integrity · availability
—
Fix status
Fixed

No CVSS vector from any source. Fix status from GitHub. Impact type from CWE-506.

Summary

### Who is affected? This advisory only applies to developers who use MetaMask SDK in the browser and who, on Sept 8th 2025 between 13:00–15:30 UTC, performed one of the following actions and then deployed their application: - Installed MetaMask SDK into a project with a lockfile for the first time - Installed MetaMask SDK in a project without a lockfile - Updated a lockfile to pull in `[email protected]` (e.g., via `npm update` or `yarn upgrade`) ### What happened? On Sept 8th, 2025 (13:00–15:30 UTC), a malicious version of the `debug` package (v4.4.2) was published to npm. The injected code attempts to interfere with dApp-to-wallet communication when executed in a browser context. While MetaMask SDK itself was not directly impacted, projects installing the SDK during this window may have inadvertently pulled in the malicious version of `debug`. ### Mitigation - If your application was rebuilt and redeployed after Sept 8th, 2025, 15:30 UTC, the malicious version of debug should no longer be present. Please also verify that your package manager (npm, yarn, pnpm, etc.) is not caching `[email protected]`. - If you have not yet deployed since performing one of the actions above, delete your `node_modules` and reinstall dependencies before deploying. - If your application was deployed during the attack window and has not been rebuilt since, perform a clean install of dependencies and redeploy to ensure the malicious package is removed. ### Resources [GitHub Advisory for debug](https://github.com/advisories/GHSA-8mgj-vmr8-frr6)

Why it matters now

Fix Fixed @metamask/sdk (npm): 0.33.1@metamask/sdk-react (npm): 0.33.1+1 more product

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
—@metamask/sdk (npm)0.16.0 to before 0.33.10.33.1Patch availableGHSA-qj3p-xc97-xw74
—@metamask/sdk-react (npm)0.16.0 to before 0.33.10.33.1Patch availableGHSA-qj3p-xc97-xw74
—@metamask/sdk-communication-layer (npm)0.16.0 to before 0.33.10.33.1Patch availableGHSA-qj3p-xc97-xw74
  • @metamask/sdk (npm) Vendor— Affected 0.16.0 to before 0.33.1 Fixed in 0.33.1 Patch available GHSA-qj3p-xc97-xw74
  • @metamask/sdk-react (npm) Vendor— Affected 0.16.0 to before 0.33.1 Fixed in 0.33.1 Patch available GHSA-qj3p-xc97-xw74
  • @metamask/sdk-communication-layer (npm) Vendor— Affected 0.16.0 to before 0.33.1 Fixed in 0.33.1 Patch available GHSA-qj3p-xc97-xw74

Remediation

  • Fix · GHSA-qj3p-xc97-xw74 @metamask/sdk (npm) Fixed in 0.33.1 Advisory →
  • Fix · GHSA-qj3p-xc97-xw74 @metamask/sdk-react (npm) Fixed in 0.33.1 Advisory →
  • Fix · GHSA-qj3p-xc97-xw74 @metamask/sdk-communication-layer (npm) Fixed in 0.33.1 Advisory →

Timeline

  1. 2026-10-03 Threatist record created from GHSA-qj3p-xc97-xw74

References

Sources

This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences