Read the docs
TI-2025-43779 Aliases GHSA-hjfh-5jmm-xr24

laravel-auth0 SDK Does Not Properly Handle File Types in Bulk User Import

Priority LOW 38CWE-434Published · Updated

Key facts

Attack vector
—
Privileges required
—
User interaction
—
Attack complexity
—
Impact type
Code execution
Confidentiality · integrity · availability
—
Fix status
Fixed

No CVSS vector from any source. Fix status from GitHub. Impact type from CWE-434.

Summary

### Overview In applications built with the Auth0-PHP SDK, the Bulk User Import endpoint does not validate the file path wrapper or value. Without proper validation, affected applications may accept arbitrary file paths or URLs. ### Am I affected? You are affected by this vulnerability if you meet the following preconditions: 1. Applications using the Auth0 laravel-auth0 SDK with version between 4.0.0 and 7.18.0, 2. Auth0 laravel-auth0 SDK uses the Auth0-PHP SDK with versions between 3.3.0 and 8.16.0. ### Fix Upgrade Auth0 laravel-auth0 SDK to version 7.19.0 or greater. ### Acknowledgement Okta would like to thank Mohamed Amine Saidani (pwni) for discovering this vulnerability.

Why it matters now

Fix Fixed auth0/login (Packagist): 7.19.0

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
—auth0/login (Packagist)4.0.0 to before 7.19.07.19.0Patch availableGHSA-hjfh-5jmm-xr24
  • auth0/login (Packagist) Vendor— Affected 4.0.0 to before 7.19.0 Fixed in 7.19.0 Patch available GHSA-hjfh-5jmm-xr24

Remediation

  • Fix · GHSA-hjfh-5jmm-xr24 auth0/login (Packagist) Fixed in 7.19.0 Advisory →

Timeline

  1. 2026-10-03 Threatist record created from GHSA-hjfh-5jmm-xr24

References

Sources

This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences