Auth0 Symfony SDK Does Not Properly Handle File Types in Bulk User Import
Key facts
- Attack vector
- —
- Privileges required
- —
- User interaction
- —
- Attack complexity
- —
- Impact type
- Code execution
- Confidentiality · integrity · availability
- —
- Fix status
- Fixed
No CVSS vector from any source. Fix status from GitHub. Impact type from CWE-434.
Summary
### Overview In applications built with the Auth0-PHP SDK, the Bulk User Import endpoint does not validate the file path wrapper or value. Without proper validation, affected applications may accept arbitrary file paths or URLs. ### Am I affected? You are affected by this vulnerability if you meet the following preconditions: 1. Applications using the Auth0 Symfony SDK with versions between 2.0.2 and 5.4.1, 2. Auth0 Symfony SDK uses the Auth0-PHP SDK with versions between 3.3.0 and 8.16.0. ### Fix Upgrade Auth0/symfony to version 5.5.0 or greater. ### Acknowledgement Okta would like to thank Mohamed Amine Saidani (pwni) for discovering this vulnerability.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | auth0/symfony (Packagist) | 2.0.2 to before 5.5.0 | 5.5.0 | Patch available | GHSA-7jp2-5h22-m432 |
- auth0/symfony (Packagist) Vendor— Affected 2.0.2 to before 5.5.0 Fixed in 5.5.0 Patch available GHSA-7jp2-5h22-m432
Remediation
- Fix · GHSA-7jp2-5h22-m432 auth0/symfony (Packagist) Fixed in 5.5.0 Advisory →
Timeline
- 2026-10-03 Threatist record created from GHSA-7jp2-5h22-m432
References
Sources
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences