Read the docs
TI-2025-43790 Aliases GHSA-28gg-8qqj-fhh5

OpenSearch Data Prepper uses deprecated SSL protocol identifier

Priority LOW 38CWE-295Published · Updated

Key facts

Attack vector
—
Privileges required
—
User interaction
—
Attack complexity
—
Impact type
Spoofing
Confidentiality · integrity · availability
—
Fix status
Fixed

No CVSS vector from any source. Fix status from GitHub. Impact type from CWE-295.

Summary

### Impact The GeoIP processor and Kafka source and buffer were using the deprecated "SSL" protocol identifier when creating SSL contexts, potentially allowing the use of insecure SSL protocols instead of modern TLS versions. Multiple Data Prepper plugins used `SSLContext.getInstance("SSL")` which could potentially allow the use of deprecated SSL protocols (SSLv2, SSLv3) that have known security vulnerabilities. While modern Java implementations typically default to secure TLS versions even with the "SSL" identifier, explicitly using "TLS" ensures that only secure TLS protocols are negotiated. The affected components were: * GeoIP Processor: The `DBSource.initiateSSL()` method used for downloading GeoIP databases from external sources * Kafka Plugin: Both `CustomClientSslEngineFactory` and `InsecureSslEngineFactory` classes used for Kafka client connections This could potentially allow connections to negotiate weaker SSL protocols instead of enforcing modern TLS versions, reducing the security of data transmission. ### Patches Data Prepper 2.12.2 contains a fix for this issue. ### Workarounds If upgrading is not immediately possible: 1. Ensure your Java runtime is configured to disable deprecated SSL protocols 2. Use network-level controls to enforce TLS-only connections 3. Use external tools to verify that deprecated SSL protocols are not allowed.

Why it matters now

Fix Fixed org.opensearch.dataprepper.plugins:geoip-processor (Maven): 2.12.2

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
—org.opensearch.dataprepper.plugins:geoip-processor (Maven)2.4.0 to before 2.12.22.12.2Patch availableGHSA-28gg-8qqj-fhh5
  • org.opensearch.dataprepper.plugins:geoip-processor (Maven) Vendor— Affected 2.4.0 to before 2.12.2 Fixed in 2.12.2 Patch available GHSA-28gg-8qqj-fhh5

Remediation

  • Fix · GHSA-28gg-8qqj-fhh5 org.opensearch.dataprepper.plugins:geoip-processor (Maven) Fixed in 2.12.2 Advisory →

Timeline

  1. 2026-10-03 Threatist record created from GHSA-28gg-8qqj-fhh5

References

Sources

This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences