Read the docs
TI-2025-43822 Aliases GHSA-7wq2-32h4-9hc9

AWS Advanced Go Wrapper: Privilege Escalation in Aurora PostgreSQL Instance

Priority LOW 38CWE-470Published · Updated

Key facts

Attack vector
—
Privileges required
—
User interaction
—
Attack complexity
—
Impact type
—
Confidentiality · integrity · availability
—
Fix status
Fixed

No CVSS vector from any source. Fix status from GitHub.

Summary

### Description of Vulnerability: An issue in AWS Wrappers for Amazon Aurora PostgreSQL may allow for privilege escalation to rds_superuser role. A low privilege authenticated user can create a crafted function that could be executed with permissions of other Amazon Relational Database Service (RDS) users. We recommend customers upgrade to the following versions: AWS Go Wrapper to 2025-10-17 ### Source of Vulnerability Report: Allistair Ishmael Hakim [[email protected]](mailto:[email protected]) ### Affected products & versions: AWS Go Wrapper < 2025-10-17 ### Platforms: MacOS/Windows/Linux

Why it matters now

Fix Fixed github.com/aws/aws-advanced-go-wrapper/awssql (Go): 1.1.1github.com/aws/aws-advanced-go-wrapper/auth-helpers (Go): 1.0.2+8 more products

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
—github.com/aws/aws-advanced-go-wrapper/awssql (Go)before 1.1.11.1.1Patch availableGHSA-7wq2-32h4-9hc9
—github.com/aws/aws-advanced-go-wrapper/auth-helpers (Go)before 1.0.21.0.2Patch availableGHSA-7wq2-32h4-9hc9
—github.com/aws/aws-advanced-go-wrapper/aws-secrets-manager (Go)before 1.0.21.0.2Patch availableGHSA-7wq2-32h4-9hc9
—github.com/aws/aws-advanced-go-wrapper/federated-auth (Go)before 1.0.21.0.2Patch availableGHSA-7wq2-32h4-9hc9
—github.com/aws/aws-advanced-go-wrapper/iam (Go)before 1.0.21.0.2Patch availableGHSA-7wq2-32h4-9hc9
—github.com/aws/aws-advanced-go-wrapper/mysql-driver (Go)before 1.0.21.0.2Patch availableGHSA-7wq2-32h4-9hc9
—github.com/aws/aws-advanced-go-wrapper/okta (Go)before 1.0.21.0.2Patch availableGHSA-7wq2-32h4-9hc9
—github.com/aws/aws-advanced-go-wrapper/otlp (Go)before 1.0.21.0.2Patch availableGHSA-7wq2-32h4-9hc9
—github.com/aws/aws-advanced-go-wrapper/pgx-driver (Go)before 1.0.21.0.2Patch availableGHSA-7wq2-32h4-9hc9
—github.com/aws/aws-advanced-go-wrapper/xray (Go)before 1.0.21.0.2Patch availableGHSA-7wq2-32h4-9hc9
  • github.com/aws/aws-advanced-go-wrapper/awssql (Go) Vendor— Affected before 1.1.1 Fixed in 1.1.1 Patch available GHSA-7wq2-32h4-9hc9
  • github.com/aws/aws-advanced-go-wrapper/auth-helpers (Go) Vendor— Affected before 1.0.2 Fixed in 1.0.2 Patch available GHSA-7wq2-32h4-9hc9
  • github.com/aws/aws-advanced-go-wrapper/aws-secrets-manager (Go) Vendor— Affected before 1.0.2 Fixed in 1.0.2 Patch available GHSA-7wq2-32h4-9hc9
  • github.com/aws/aws-advanced-go-wrapper/federated-auth (Go) Vendor— Affected before 1.0.2 Fixed in 1.0.2 Patch available GHSA-7wq2-32h4-9hc9
  • github.com/aws/aws-advanced-go-wrapper/iam (Go) Vendor— Affected before 1.0.2 Fixed in 1.0.2 Patch available GHSA-7wq2-32h4-9hc9
  • github.com/aws/aws-advanced-go-wrapper/mysql-driver (Go) Vendor— Affected before 1.0.2 Fixed in 1.0.2 Patch available GHSA-7wq2-32h4-9hc9
  • github.com/aws/aws-advanced-go-wrapper/okta (Go) Vendor— Affected before 1.0.2 Fixed in 1.0.2 Patch available GHSA-7wq2-32h4-9hc9
  • github.com/aws/aws-advanced-go-wrapper/otlp (Go) Vendor— Affected before 1.0.2 Fixed in 1.0.2 Patch available GHSA-7wq2-32h4-9hc9
  • github.com/aws/aws-advanced-go-wrapper/pgx-driver (Go) Vendor— Affected before 1.0.2 Fixed in 1.0.2 Patch available GHSA-7wq2-32h4-9hc9
  • github.com/aws/aws-advanced-go-wrapper/xray (Go) Vendor— Affected before 1.0.2 Fixed in 1.0.2 Patch available GHSA-7wq2-32h4-9hc9

Remediation

  • Fix · GHSA-7wq2-32h4-9hc9 github.com/aws/aws-advanced-go-wrapper/awssql (Go) Fixed in 1.1.1 Advisory →
  • Fix · GHSA-7wq2-32h4-9hc9 github.com/aws/aws-advanced-go-wrapper/auth-helpers (Go) Fixed in 1.0.2 Advisory →
  • Fix · GHSA-7wq2-32h4-9hc9 github.com/aws/aws-advanced-go-wrapper/aws-secrets-manager (Go) Fixed in 1.0.2 Advisory →
  • Fix · GHSA-7wq2-32h4-9hc9 github.com/aws/aws-advanced-go-wrapper/federated-auth (Go) Fixed in 1.0.2 Advisory →
  • Fix · GHSA-7wq2-32h4-9hc9 github.com/aws/aws-advanced-go-wrapper/iam (Go) Fixed in 1.0.2 Advisory →
  • Fix · GHSA-7wq2-32h4-9hc9 github.com/aws/aws-advanced-go-wrapper/mysql-driver (Go) Fixed in 1.0.2 Advisory →
  • Fix · GHSA-7wq2-32h4-9hc9 github.com/aws/aws-advanced-go-wrapper/okta (Go) Fixed in 1.0.2 Advisory →
  • Fix · GHSA-7wq2-32h4-9hc9 github.com/aws/aws-advanced-go-wrapper/otlp (Go) Fixed in 1.0.2 Advisory →
  • Fix · GHSA-7wq2-32h4-9hc9 github.com/aws/aws-advanced-go-wrapper/pgx-driver (Go) Fixed in 1.0.2 Advisory →
  • Fix · GHSA-7wq2-32h4-9hc9 github.com/aws/aws-advanced-go-wrapper/xray (Go) Fixed in 1.0.2 Advisory →

Timeline

  1. 2026-10-03 Threatist record created from GHSA-7wq2-32h4-9hc9

References

Sources

This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences