Read the docs
TI-2025-43836 Aliases GHSA-j4gv-6x9v-v23g

OMERO.web uses jquery-form library, which may be vulnerable to XSS attack

Priority LOW 38CWE-79Published · Updated

Key facts

Attack vector
—
Privileges required
—
User interaction
—
Attack complexity
—
Impact type
Cross-site scripting
Confidentiality · integrity · availability
—
Fix status
Fixed

No CVSS vector from any source. Fix status from GitHub. Impact type from CWE-79.

Summary

### Impact OMERO.web uses the jquery-form library throughout to handle form submission and response processing. Due to some unpatched potential vulnerabilities in jquery-form, OMERO.web 5.29.2 and earlier may be susceptible to XSS attacks. ### Patches User should upgrade OMERO.web to 5.29.3 or higher. ### Workarounds None. ### Resources https://github.com/jquery-form/form/issues/604

Why it matters now

Fix Fixed omero-web (PyPI): 5.29.3

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
—omero-web (PyPI)before 5.29.35.29.3Patch availableGHSA-j4gv-6x9v-v23g
  • omero-web (PyPI) Vendor— Affected before 5.29.3 Fixed in 5.29.3 Patch available GHSA-j4gv-6x9v-v23g

Remediation

  • Fix · GHSA-j4gv-6x9v-v23g omero-web (PyPI) Fixed in 5.29.3 Advisory →

Timeline

  1. 2026-10-03 Threatist record created from GHSA-j4gv-6x9v-v23g

References

Sources

This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences