Next.js is vulnerable to RCE in React flight protocol
Key facts
- Attack vector
- —
- Privileges required
- —
- User interaction
- —
- Attack complexity
- —
- Impact type
- Code execution
- Confidentiality · integrity · availability
- —
- Fix status
- Fixed
No CVSS vector from any source. Fix status from GitHub. Impact type from CWE-502.
Summary
A vulnerability affects certain React packages<sup>1</sup> for versions 19.0.0, 19.1.0, 19.1.1, and 19.2.0 and frameworks that use the affected packages, including Next.js 15.x and 16.x using the App Router. The issue is tracked upstream as [CVE-2025-55182](https://www.cve.org/CVERecord?id=CVE-2025-55182). Fixed in: React: 19.0.1, 19.1.2, 19.2.1 Next.js: 15.0.5, 15.1.9, 15.2.6, 15.3.6, 15.4.8, 15.5.7, 16.0.7, 15.6.0-canary.58, 16.1.0-canary.12+ The vulnerability also affects experimental canary releases starting with 14.3.0-canary.77. Users on any of the 14.3 canary builds should either downgrade to a 14.x stable release or 14.3.0-canary.76. All users of stable 15.x or 16.x Next.js versions should upgrade to a patched, stable version immediately. <sup>1</sup> The affected React packages are: - react-server-dom-parcel - react-server-dom-turbopack - react-server-dom-webpack
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | next (npm) | 14.3.0-canary.77 to before 15.0.5 | 15.0.5 | Patch available | GHSA-9qr9-h5gf-34mp |
| — | next (npm) | 15.1.0-canary.0 to before 15.1.9 | 15.1.9 | Patch available | GHSA-9qr9-h5gf-34mp |
| — | next (npm) | 15.2.0-canary.0 to before 15.2.6 | 15.2.6 | Patch available | GHSA-9qr9-h5gf-34mp |
| — | next (npm) | 15.3.0-canary.0 to before 15.3.6 | 15.3.6 | Patch available | GHSA-9qr9-h5gf-34mp |
| — | next (npm) | 15.4.0-canary.0 to before 15.4.8 | 15.4.8 | Patch available | GHSA-9qr9-h5gf-34mp |
| — | next (npm) | 15.5.0-canary.0 to before 15.5.7 | 15.5.7 | Patch available | GHSA-9qr9-h5gf-34mp |
| — | next (npm) | 16.0.0-canary.0 to before 16.0.7 | 16.0.7 | Patch available | GHSA-9qr9-h5gf-34mp |
- next (npm) Vendor— Affected 14.3.0-canary.77 to before 15.0.5 Fixed in 15.0.5 Patch available GHSA-9qr9-h5gf-34mp
- next (npm) Vendor— Affected 15.1.0-canary.0 to before 15.1.9 Fixed in 15.1.9 Patch available GHSA-9qr9-h5gf-34mp
- next (npm) Vendor— Affected 15.2.0-canary.0 to before 15.2.6 Fixed in 15.2.6 Patch available GHSA-9qr9-h5gf-34mp
- next (npm) Vendor— Affected 15.3.0-canary.0 to before 15.3.6 Fixed in 15.3.6 Patch available GHSA-9qr9-h5gf-34mp
- next (npm) Vendor— Affected 15.4.0-canary.0 to before 15.4.8 Fixed in 15.4.8 Patch available GHSA-9qr9-h5gf-34mp
- next (npm) Vendor— Affected 15.5.0-canary.0 to before 15.5.7 Fixed in 15.5.7 Patch available GHSA-9qr9-h5gf-34mp
- next (npm) Vendor— Affected 16.0.0-canary.0 to before 16.0.7 Fixed in 16.0.7 Patch available GHSA-9qr9-h5gf-34mp
Remediation
- Fix · GHSA-9qr9-h5gf-34mp next (npm) Fixed in 15.0.5 Advisory →
- Fix · GHSA-9qr9-h5gf-34mp next (npm) Fixed in 15.1.9 Advisory →
- Fix · GHSA-9qr9-h5gf-34mp next (npm) Fixed in 15.2.6 Advisory →
- Fix · GHSA-9qr9-h5gf-34mp next (npm) Fixed in 15.3.6 Advisory →
- Fix · GHSA-9qr9-h5gf-34mp next (npm) Fixed in 15.4.8 Advisory →
- Fix · GHSA-9qr9-h5gf-34mp next (npm) Fixed in 15.5.7 Advisory →
- Fix · GHSA-9qr9-h5gf-34mp next (npm) Fixed in 16.0.7 Advisory →
Timeline
- 2026-10-03 Threatist record created from GHSA-9qr9-h5gf-34mp
References
Sources
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences