Read the docs
TI-2025-43843 Aliases GHSA-fmh4-wr37-44fp

React Server Components are Vulnerable to RCE

Priority LOW 38CWE-502Published · Updated

Key facts

Attack vector
—
Privileges required
—
User interaction
—
Attack complexity
—
Impact type
Code execution
Confidentiality · integrity · availability
—
Fix status
Fixed

No CVSS vector from any source. Fix status from GitHub. Impact type from CWE-502.

Summary

### Summary `@vitejs/plugin-rsc` vendors `react-server-dom-webpack`, which contained an unauthenticated remote code execution vulnerability in versions prior to 19.0.1, 19.1.2, and 19.2.1. See details in React repository's advisory https://github.com/facebook/react/security/advisories/GHSA-fv66-9v8q-g76r ### Impact Applications using affected versions of `@vitejs/plugin-rsc` are vulnerable to unauthenticated remote code execution through deserialization of untrusted data. An attacker can execute arbitrary code remotely without authentication, affecting confidentiality, integrity, and availability. ### Recommendations Upgrade immediately to `@vitejs/[email protected]` or later. ### Workarounds Applications not using server-side React or React Server Components are unaffected.

Why it matters now

Fix Fixed @vitejs/plugin-rsc (npm): 0.5.3

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
—@vitejs/plugin-rsc (npm)before 0.5.30.5.3Patch availableGHSA-fmh4-wr37-44fp
  • @vitejs/plugin-rsc (npm) Vendor— Affected before 0.5.3 Fixed in 0.5.3 Patch available GHSA-fmh4-wr37-44fp

Remediation

  • Fix · GHSA-fmh4-wr37-44fp @vitejs/plugin-rsc (npm) Fixed in 0.5.3 Advisory →

Timeline

  1. 2026-10-03 Threatist record created from GHSA-fmh4-wr37-44fp

References

Sources

This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences