SAML PHP Toolkit Vulnerability on xmlseclibs CVE-2025-66475
Key facts
- Attack vector
- —
- Privileges required
- —
- User interaction
- —
- Attack complexity
- —
- Impact type
- —
- Confidentiality · integrity · availability
- —
- Fix status
- Fixed
No CVSS vector from any source. Fix status from GitHub.
Summary
**Summary** There is a critical vulnerability on xmlseclibs [CVE-2025-66475](https://github.com/robrichards/xmlseclibs/security/advisories/GHSA-c4cc-x928-vjw9), a dependency of php-saml Update to the following versions of php-saml which forces the use of patched versions of xmlseclibs: - [2.21.1](https://github.com/SAML-Toolkits/php-saml/releases/tag/2.21.1) - [3.8.1](https://github.com/SAML-Toolkits/php-saml/releases/tag/3.8.1) - [4.3.1](https://github.com/SAML-Toolkits/php-saml/releases/tag/4.3.1) **Impact** Signature Wrapping Vulnerabilities allows an attacker to impersonate a user.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | onelogin/php-saml (Packagist) | before 2.21.1 | 2.21.1 | Patch available | GHSA-5j8p-438x-rgg5 |
| — | onelogin/php-saml (Packagist) | 3.0.0 to before 3.8.1 | 3.8.1 | Patch available | GHSA-5j8p-438x-rgg5 |
| — | onelogin/php-saml (Packagist) | 4.0.0 to before 4.3.1 | 4.3.1 | Patch available | GHSA-5j8p-438x-rgg5 |
- onelogin/php-saml (Packagist) Vendor— Affected before 2.21.1 Fixed in 2.21.1 Patch available GHSA-5j8p-438x-rgg5
- onelogin/php-saml (Packagist) Vendor— Affected 3.0.0 to before 3.8.1 Fixed in 3.8.1 Patch available GHSA-5j8p-438x-rgg5
- onelogin/php-saml (Packagist) Vendor— Affected 4.0.0 to before 4.3.1 Fixed in 4.3.1 Patch available GHSA-5j8p-438x-rgg5
Remediation
- Fix · GHSA-5j8p-438x-rgg5 onelogin/php-saml (Packagist) Fixed in 2.21.1 Advisory →
- Fix · GHSA-5j8p-438x-rgg5 onelogin/php-saml (Packagist) Fixed in 3.8.1 Advisory →
- Fix · GHSA-5j8p-438x-rgg5 onelogin/php-saml (Packagist) Fixed in 4.3.1 Advisory →
Timeline
- 2026-10-03 Threatist record created from GHSA-5j8p-438x-rgg5
References
Other 6
- https://github.com/SAML-Toolkits/php-saml/security/advisories/GHSA-5j8p-438x-rgg5
- https://github.com/robrichards/xmlseclibs/security/advisories/GHSA-c4cc-x928-vjw9
- https://github.com/SAML-Toolkits/php-saml
- https://github.com/SAML-Toolkits/php-saml/releases/tag/2.21.1
- https://github.com/SAML-Toolkits/php-saml/releases/tag/3.8.1
- https://github.com/SAML-Toolkits/php-saml/releases/tag/4.3.1
Sources
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences