Next Vulnerable to Denial of Service with Server Components
Key facts
- Attack vector
- —
- Privileges required
- —
- User interaction
- —
- Attack complexity
- —
- Impact type
- Denial of service, Code execution
- Confidentiality · integrity · availability
- —
- Fix status
- Fixed
No CVSS vector from any source. Fix status from GitHub. Impact type from CWE-400 and CWE-502.
Summary
A vulnerability affects certain React packages for versions 19.0.0, 19.0.1, 19.1.0, 19.1.1, 19.1.2, 19.2.0, and 19.2.1 and frameworks that use the affected packages, including Next.js 15.x and 16.x using the App Router. The issue is tracked upstream as [CVE-2025-55184](https://www.cve.org/CVERecord?id=CVE-2025-55184). A malicious HTTP request can be crafted and sent to any App Router endpoint that, when deserialized, can cause the server process to hang and consume CPU. This can result in denial of service in unpatched environments.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | next (npm) | 13.3.0 to before 14.2.34 | 14.2.34 | Patch available | GHSA-mwv6-3258-q52c |
| — | next (npm) | 15.0.0-canary.0 to before 15.0.6 | 15.0.6 | Patch available | GHSA-mwv6-3258-q52c |
| — | next (npm) | 15.1.1-canary.0 to before 15.1.10 | 15.1.10 | Patch available | GHSA-mwv6-3258-q52c |
| — | next (npm) | 15.2.0-canary.0 to before 15.2.7 | 15.2.7 | Patch available | GHSA-mwv6-3258-q52c |
| — | next (npm) | 15.3.0-canary.0 to before 15.3.7 | 15.3.7 | Patch available | GHSA-mwv6-3258-q52c |
| — | next (npm) | 15.4.0-canary.0 to before 15.4.9 | 15.4.9 | Patch available | GHSA-mwv6-3258-q52c |
| — | next (npm) | 15.5.1-canary.0 to before 15.5.8 | 15.5.8 | Patch available | GHSA-mwv6-3258-q52c |
| — | next (npm) | 15.6.0-canary.0 to before 15.6.0-canary.59 | 15.6.0-canary.59 | Patch available | GHSA-mwv6-3258-q52c |
| — | next (npm) | 16.0.0-beta.0 to before 16.0.9 | 16.0.9 | Patch available | GHSA-mwv6-3258-q52c |
| — | next (npm) | 16.1.0-canary.0 to before 16.1.0-canary.17 | 16.1.0-canary.17 | Patch available | GHSA-mwv6-3258-q52c |
- next (npm) Vendor— Affected 13.3.0 to before 14.2.34 Fixed in 14.2.34 Patch available GHSA-mwv6-3258-q52c
- next (npm) Vendor— Affected 15.0.0-canary.0 to before 15.0.6 Fixed in 15.0.6 Patch available GHSA-mwv6-3258-q52c
- next (npm) Vendor— Affected 15.1.1-canary.0 to before 15.1.10 Fixed in 15.1.10 Patch available GHSA-mwv6-3258-q52c
- next (npm) Vendor— Affected 15.2.0-canary.0 to before 15.2.7 Fixed in 15.2.7 Patch available GHSA-mwv6-3258-q52c
- next (npm) Vendor— Affected 15.3.0-canary.0 to before 15.3.7 Fixed in 15.3.7 Patch available GHSA-mwv6-3258-q52c
- next (npm) Vendor— Affected 15.4.0-canary.0 to before 15.4.9 Fixed in 15.4.9 Patch available GHSA-mwv6-3258-q52c
- next (npm) Vendor— Affected 15.5.1-canary.0 to before 15.5.8 Fixed in 15.5.8 Patch available GHSA-mwv6-3258-q52c
- next (npm) Vendor— Affected 15.6.0-canary.0 to before 15.6.0-canary.59 Fixed in 15.6.0-canary.59 Patch available GHSA-mwv6-3258-q52c
- next (npm) Vendor— Affected 16.0.0-beta.0 to before 16.0.9 Fixed in 16.0.9 Patch available GHSA-mwv6-3258-q52c
- next (npm) Vendor— Affected 16.1.0-canary.0 to before 16.1.0-canary.17 Fixed in 16.1.0-canary.17 Patch available GHSA-mwv6-3258-q52c
Remediation
- Fix · GHSA-mwv6-3258-q52c next (npm) Fixed in 14.2.34 Advisory →
- Fix · GHSA-mwv6-3258-q52c next (npm) Fixed in 15.0.6 Advisory →
- Fix · GHSA-mwv6-3258-q52c next (npm) Fixed in 15.1.10 Advisory →
- Fix · GHSA-mwv6-3258-q52c next (npm) Fixed in 15.2.7 Advisory →
- Fix · GHSA-mwv6-3258-q52c next (npm) Fixed in 15.3.7 Advisory →
- Fix · GHSA-mwv6-3258-q52c next (npm) Fixed in 15.4.9 Advisory →
- Fix · GHSA-mwv6-3258-q52c next (npm) Fixed in 15.5.8 Advisory →
- Fix · GHSA-mwv6-3258-q52c next (npm) Fixed in 15.6.0-canary.59 Advisory →
- Fix · GHSA-mwv6-3258-q52c next (npm) Fixed in 16.0.9 Advisory →
- Fix · GHSA-mwv6-3258-q52c next (npm) Fixed in 16.1.0-canary.17 Advisory →
Timeline
- 2026-10-03 Threatist record created from GHSA-mwv6-3258-q52c
References
Sources
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences