Read the docs
TI-2025-43854 Aliases GHSA-cpqf-f22c-r95x

Vite Plugin React has a Denial of Service Vulnerability in React Server Components

Priority LOW 38CWE-1395Published · Updated

Key facts

Attack vector
—
Privileges required
—
User interaction
—
Attack complexity
—
Impact type
Denial of service, Code execution
Confidentiality · integrity · availability
—
Fix status
Fixed

No CVSS vector from any source. Fix status from GitHub. Impact type from CWE-400 and CWE-502.

Summary

### Impact `@vitejs/plugin-rsc` vendors `react-server-dom-webpack`, which contained a vulnerability in versions prior to 19.2.3. See details in React repository's advisory https://github.com/facebook/react/security/advisories/GHSA-7gmr-mq3h-m5h9 ### Patches Upgrade immediately to `@vitejs/[email protected]` or later.

Why it matters now

Fix Fixed @vitejs/plugin-rsc (npm): 0.5.7

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
—@vitejs/plugin-rsc (npm)before 0.5.70.5.7Patch availableGHSA-cpqf-f22c-r95x
  • @vitejs/plugin-rsc (npm) Vendor— Affected before 0.5.7 Fixed in 0.5.7 Patch available GHSA-cpqf-f22c-r95x

Remediation

  • Fix · GHSA-cpqf-f22c-r95x @vitejs/plugin-rsc (npm) Fixed in 0.5.7 Advisory →

Timeline

  1. 2026-10-03 Threatist record created from GHSA-cpqf-f22c-r95x

References

Sources

This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences