Read the docs
TI-2025-43855 Aliases GHSA-c6m7-q6pr-c64r

Vite Plugin React has a Source Code Exposure Vulnerability in React Server Components

Priority LOW 38CWE-1395Published · Updated

Key facts

Attack vector
—
Privileges required
—
User interaction
—
Attack complexity
—
Impact type
Information disclosure, Code execution
Confidentiality · integrity · availability
—
Fix status
Fixed

No CVSS vector from any source. Fix status from GitHub. Impact type from CWE-497 and CWE-502.

Summary

### Impact `@vitejs/plugin-rsc` vendors `react-server-dom-webpack`, which contained a vulnerability in versions prior to 19.2.3. See details in React repository's advisory https://github.com/facebook/react/security/advisories/GHSA-925w-6v3x-g4j4 ### Patches Upgrade immediately to `@vitejs/[email protected]` or later.

Why it matters now

Fix Fixed @vitejs/plugin-rsc (npm): 0.5.7

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
—@vitejs/plugin-rsc (npm)before 0.5.70.5.7Patch availableGHSA-c6m7-q6pr-c64r
  • @vitejs/plugin-rsc (npm) Vendor— Affected before 0.5.7 Fixed in 0.5.7 Patch available GHSA-c6m7-q6pr-c64r

Remediation

  • Fix · GHSA-c6m7-q6pr-c64r @vitejs/plugin-rsc (npm) Fixed in 0.5.7 Advisory →

Timeline

  1. 2026-10-03 Threatist record created from GHSA-c6m7-q6pr-c64r

References

Sources

This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences