Next has a Denial of Service with Server Components - Incomplete Fix Follow-Up
Key facts
- Attack vector
- —
- Privileges required
- —
- User interaction
- —
- Attack complexity
- —
- Impact type
- Denial of service, Code execution
- Confidentiality · integrity · availability
- —
- Fix status
- Fixed
No CVSS vector from any source. Fix status from GitHub. Impact type from CWE-400 and CWE-502.
Summary
It was discovered that the fix for [CVE-2025-55184](https://github.com/advisories/GHSA-2m3v-v2m8-q956) in React Server Components was incomplete and did not fully mitigate denial-of-service conditions across all payload types. As a result, certain crafted inputs could still trigger excessive resource consumption. This vulnerability affects React versions 19.0.2, 19.1.3, and 19.2.2, as well as frameworks that bundle or depend on these versions, including Next.js 13.x, 14.x, 15.x, and 16.x when using the App Router. The issue is tracked upstream as [CVE-2025-67779](https://www.cve.org/CVERecord?id=CVE-2025-67779). A malicious actor can send a specially crafted HTTP request to a Server Function endpoint that, when deserialized, causes the React Server Components runtime to enter an infinite loop. This can lead to sustained CPU consumption and cause the affected server process to become unresponsive, resulting in a denial-of-service condition in unpatched environments.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | next (npm) | 13.3.1-canary.0 to before 14.2.35 | 14.2.35 | Patch available | GHSA-5j59-xgg2-r9c4 |
| — | next (npm) | 15.0.6 to before 15.0.7 | 15.0.7 | Patch available | GHSA-5j59-xgg2-r9c4 |
| — | next (npm) | 15.1.10 to before 15.1.11 | 15.1.11 | Patch available | GHSA-5j59-xgg2-r9c4 |
| — | next (npm) | 15.2.7 to before 15.2.8 | 15.2.8 | Patch available | GHSA-5j59-xgg2-r9c4 |
| — | next (npm) | 15.3.7 to before 15.3.8 | 15.3.8 | Patch available | GHSA-5j59-xgg2-r9c4 |
| — | next (npm) | 15.4.9 to before 15.4.10 | 15.4.10 | Patch available | GHSA-5j59-xgg2-r9c4 |
| — | next (npm) | 15.5.8 to before 15.5.9 | 15.5.9 | Patch available | GHSA-5j59-xgg2-r9c4 |
| — | next (npm) | 15.6.0-canary.59 to before 15.6.0-canary.60 | 15.6.0-canary.60 | Patch available | GHSA-5j59-xgg2-r9c4 |
| — | next (npm) | 16.0.9 to before 16.0.10 | 16.0.10 | Patch available | GHSA-5j59-xgg2-r9c4 |
| — | next (npm) | 16.1.0-canary.17 to before 16.1.0-canary.19 | 16.1.0-canary.19 | Patch available | GHSA-5j59-xgg2-r9c4 |
- next (npm) Vendor— Affected 13.3.1-canary.0 to before 14.2.35 Fixed in 14.2.35 Patch available GHSA-5j59-xgg2-r9c4
- next (npm) Vendor— Affected 15.0.6 to before 15.0.7 Fixed in 15.0.7 Patch available GHSA-5j59-xgg2-r9c4
- next (npm) Vendor— Affected 15.1.10 to before 15.1.11 Fixed in 15.1.11 Patch available GHSA-5j59-xgg2-r9c4
- next (npm) Vendor— Affected 15.2.7 to before 15.2.8 Fixed in 15.2.8 Patch available GHSA-5j59-xgg2-r9c4
- next (npm) Vendor— Affected 15.3.7 to before 15.3.8 Fixed in 15.3.8 Patch available GHSA-5j59-xgg2-r9c4
- next (npm) Vendor— Affected 15.4.9 to before 15.4.10 Fixed in 15.4.10 Patch available GHSA-5j59-xgg2-r9c4
- next (npm) Vendor— Affected 15.5.8 to before 15.5.9 Fixed in 15.5.9 Patch available GHSA-5j59-xgg2-r9c4
- next (npm) Vendor— Affected 15.6.0-canary.59 to before 15.6.0-canary.60 Fixed in 15.6.0-canary.60 Patch available GHSA-5j59-xgg2-r9c4
- next (npm) Vendor— Affected 16.0.9 to before 16.0.10 Fixed in 16.0.10 Patch available GHSA-5j59-xgg2-r9c4
- next (npm) Vendor— Affected 16.1.0-canary.17 to before 16.1.0-canary.19 Fixed in 16.1.0-canary.19 Patch available GHSA-5j59-xgg2-r9c4
Remediation
- Fix · GHSA-5j59-xgg2-r9c4 next (npm) Fixed in 14.2.35 Advisory →
- Fix · GHSA-5j59-xgg2-r9c4 next (npm) Fixed in 15.0.7 Advisory →
- Fix · GHSA-5j59-xgg2-r9c4 next (npm) Fixed in 15.1.11 Advisory →
- Fix · GHSA-5j59-xgg2-r9c4 next (npm) Fixed in 15.2.8 Advisory →
- Fix · GHSA-5j59-xgg2-r9c4 next (npm) Fixed in 15.3.8 Advisory →
- Fix · GHSA-5j59-xgg2-r9c4 next (npm) Fixed in 15.4.10 Advisory →
- Fix · GHSA-5j59-xgg2-r9c4 next (npm) Fixed in 15.5.9 Advisory →
- Fix · GHSA-5j59-xgg2-r9c4 next (npm) Fixed in 15.6.0-canary.60 Advisory →
- Fix · GHSA-5j59-xgg2-r9c4 next (npm) Fixed in 16.0.10 Advisory →
- Fix · GHSA-5j59-xgg2-r9c4 next (npm) Fixed in 16.1.0-canary.19 Advisory →
Timeline
- 2026-10-03 Threatist record created from GHSA-5j59-xgg2-r9c4
References
Other 6
- https://github.com/vercel/next.js/security/advisories/GHSA-5j59-xgg2-r9c4
- https://github.com/vercel/next.js
- https://nextjs.org/blog/security-update-2025-12-11
- https://react.dev/blog/2025/12/11/denial-of-service-and-source-code-exposure-in-react-server-components
- https://www.cve.org/CVERecord?id=CVE-2025-55184
- https://www.facebook.com/security/advisories/cve-2025-67779
Sources
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences