Auth0 Laravel SDK has Improper Audience Validation via Auth0-PHP SDK dependency
Key facts
- Attack vector
- —
- Privileges required
- —
- User interaction
- —
- Attack complexity
- —
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- —
- Fix status
- Fixed
No CVSS vector from any source. Fix status from GitHub. Impact type from CWE-863.
Summary
### Description In applications built with the Auth0-PHP SDK, the audience validation in access tokens is performed improperly. Without proper validation, affected applications may accept ID tokens as Access tokens. ### Affected product and versions Users are affected if they meet the following preconditions: - Applications using the Auth0 laravel-auth0 SDK with versions between 7.0.0 and 7.19.0, - Auth0 laravel-auth0 SDK uses the Auth0-PHP SDK with versions between 8.0.0 and 8.17.0. ### Resolution Upgrade Auth0/laravel-auth0 to version 7.20.0 or greater. ### Acknowledgement Okta would like to thank Jafar Sadiq (iaf4r) for their discovery and responsible disclosure.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | auth0/login (Packagist) | 7.0.0 to before 7.20.0 | 7.20.0 | Patch available | GHSA-7hh9-gp72-wh7h |
- auth0/login (Packagist) Vendor— Affected 7.0.0 to before 7.20.0 Fixed in 7.20.0 Patch available GHSA-7hh9-gp72-wh7h
Remediation
- Fix · GHSA-7hh9-gp72-wh7h auth0/login (Packagist) Fixed in 7.20.0 Advisory →
Timeline
- 2026-10-03 Threatist record created from GHSA-7hh9-gp72-wh7h
References
Sources
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences