Read the docs
TI-2025-43860 Aliases GHSA-f3r2-88mq-9v4g

Auth0 Symfony SDK has Improper Audience Validation via Auth0-PHP SDK

Priority LOW 38CWE-1395Published · Updated

Key facts

Attack vector
—
Privileges required
—
User interaction
—
Attack complexity
—
Impact type
Security bypass
Confidentiality · integrity · availability
—
Fix status
Fixed

No CVSS vector from any source. Fix status from GitHub. Impact type from CWE-345.

Summary

### Description In applications built with the Auth0-PHP SDK, the audience validation in access tokens is performed improperly. Without proper validation, affected applications may accept ID tokens as Access tokens. ### Affected product and versions Projects are affected if they meet the following preconditions: - Applications using the Auth0 Symfony SDK with versions between 5.0.0 and 5.5.0 - Auth0 Symfony SDK uses the Auth0-PHP SDK with versions between 8.0.0 and 8.17.0. ### Resolution Upgrade Auth0/symfony to version 5.6.0 or greater. ### Acknowledgement Okta would like to thank Jafar Sadiq (iaf4r) for their discovery and responsible disclosure.

Why it matters now

Fix Fixed auth0/symfony (Packagist): 5.6.0

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
—auth0/symfony (Packagist)5.0.0 to before 5.6.05.6.0Patch availableGHSA-f3r2-88mq-9v4g
  • auth0/symfony (Packagist) Vendor— Affected 5.0.0 to before 5.6.0 Fixed in 5.6.0 Patch available GHSA-f3r2-88mq-9v4g

Remediation

  • Fix · GHSA-f3r2-88mq-9v4g auth0/symfony (Packagist) Fixed in 5.6.0 Advisory →

Timeline

  1. 2026-10-03 Threatist record created from GHSA-f3r2-88mq-9v4g

References

Sources

This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences