Auth0 WordPress has Improper Audience Validation via Auth0-PHP SDK Dependency
Key facts
- Attack vector
- —
- Privileges required
- —
- User interaction
- —
- Attack complexity
- —
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- —
- Fix status
- Fixed
No CVSS vector from any source. Fix status from GitHub. Impact type from CWE-863.
Summary
### Description In applications built with the Auth0-PHP SDK, the audience validation in access tokens is performed improperly. Without proper validation, affected applications may accept ID tokens as Access tokens. ### Affected product and versions Projects are affected if they meet the following preconditions: - Applications using the Auth0 Wordpress plugin with version between 5.0.0-BETA0 and 5.4.0, - Auth0 Wordpress plugin uses the Auth0-PHP SDK with versions between 8.0.0 and 8.17.0. ### Resolution Upgrade Auth0 Wordpress plugin to version 5.5.0 or greater. ### Acknowledgement Okta would like to thank Jafar Sadiq (iaf4r) for their discovery and responsible disclosure.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | auth0/wordpress (Packagist) | 5.0.0-BETA0 to before 5.5.0 | 5.5.0 | Patch available | GHSA-vvg7-8rmq-92g7 |
- auth0/wordpress (Packagist) Vendor— Affected 5.0.0-BETA0 to before 5.5.0 Fixed in 5.5.0 Patch available GHSA-vvg7-8rmq-92g7
Remediation
- Fix · GHSA-vvg7-8rmq-92g7 auth0/wordpress (Packagist) Fixed in 5.5.0 Advisory →
Timeline
- 2026-10-03 Threatist record created from GHSA-vvg7-8rmq-92g7
References
Sources
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences