Read the docs
TI-2025-43864 Aliases GHSA-rcfx-77hg-w2wv

FastMCP updated to MCP 1.23+ due to CVE-2025-66416

Priority LOW 38Published · Updated

Key facts

Attack vector
—
Privileges required
—
User interaction
—
Attack complexity
—
Impact type
—
Confidentiality · integrity · availability
—
Fix status
Fixed

No CVSS vector from any source. Fix status from GitHub.

Summary

There was a recent CVE report on MCP: https://nvd.nist.gov/vuln/detail/CVE-2025-66416. FastMCP does not use any of the affected components of the MCP SDK directly. However, FastMCP versions prior to 2.14.0 did allow MCP SDK versions <1.23 that were vulnerable to CVE-2025-66416. Users should upgrade to FastMCP 2.14.0 or later.

Why it matters now

Fix Fixed fastmcp (PyPI): 2.14.0

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
—fastmcp (PyPI)before 2.14.02.14.0Patch availableGHSA-rcfx-77hg-w2wv
  • fastmcp (PyPI) Vendor— Affected before 2.14.0 Fixed in 2.14.0 Patch available GHSA-rcfx-77hg-w2wv

Remediation

  • Fix · GHSA-rcfx-77hg-w2wv fastmcp (PyPI) Fixed in 2.14.0 Advisory →

Timeline

  1. 2026-10-03 Threatist record created from GHSA-rcfx-77hg-w2wv

References

Sources

This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences