LDAP injection in Frappe via unsanitized endpoint parameters
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Attack requirements
- Present
- Impact type
- —
- Confidentiality · integrity · availability
- Low · None · None
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA.
Summary
Frappe before 14.99.2 and 15.x before 15.86.0 contains an LDAP injection flaw (CWE-90) because certain endpoints do not sanitize user-supplied parameters before using them in LDAP queries. An unauthenticated remote attacker can supply crafted LDAP filter syntax through these parameters to alter the resulting directory queries.
Written with Claude Haiku 5.5 from the sources below · 2026-10-29
Description from the CNA
Frappe before 14.99.2 and 15.x before 15.86.0 contains an LDAP injection vulnerability because certain endpoints do not sanitize user-supplied parameters before using them in LDAP queries. Attackers can supply crafted LDAP filter syntax through these parameters to alter the resulting directory queries.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
Remediation
Upgrade Frappe to version 14.99.2 for the 14 line or to version 15.86.0 for the 15 line.
Written with Claude Haiku 5.5 from the sources below · 2026-10-29
- Fix · CNA frappe (frappe) Fixed in 14.99.2, 15.86.0
Timeline
- 2026-10-12 Threatist record created from CVE-2025-71431
- 2026-10-13 Alias added: GHSA-4wwr-6qhv-m4v4
- 2026-10-13 Priority changed: MEDIUM → LOW
- 2026-10-16 CISA SSVC decision points changed
References
More frappe vulnerabilities
- TI-2026-28140 ERPNext v15.103.1 and before is vulnerable to Server-Side Template Injection (SSTI). CVSS 3.1CRITICAL 9.8
- TI-2025-40873 An issue was discovered in Frappe ERPNext through 15.89.0. CVSS 3.1CRITICAL 9.8
- TI-2025-40872 An issue was discovered in Frappe ERPNext through 15.89.0. CVSS 3.1CRITICAL 9.8
- TI-2025-40871 A Server-Side Template Injection (SSTI) vulnerability exists in the Frappe ERPNext… CVSS 3.1CRITICAL 9.8
- TI-2025-32462 In Frappe ERPNext 15.57.5, the function get_rfq_containing_supplier() at… CVSS 3.1HIGH 8.2
- TI-2025-32461 In Frappe ERPNext 15.57.5, the function get_stock_balance_for() at… CVSS 3.1HIGH 8.2
Sources
- CVE-2025-71431 · CVE Program
- CVE-2025-71431 · NVD
- FIRST EPSS
- GHSA-4wwr-6qhv-m4v4 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences