Reflected XSS in Frappe ERPNext enables account takeover
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Passive
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- High · High · None
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA. Impact type from CWE-79.
Summary
Frappe ERPNext before 14.92.1 and 15.x before 15.83.0 contains a reflected cross-site scripting flaw (CWE-79) caused by missing input validation on a certain page. Remote attackers can lure a logged-in user into opening a crafted URL, which runs injected JavaScript in the victim's authenticated session and allows account takeover.
Written with Claude Haiku 5.5 from the sources below · 2026-10-29
Description from the CNA
Frappe ERPNext before 14.92.1 and 15.x before 15.83.0 contains a reflected cross-site scripting vulnerability due to missing input validation on a certain page, allowing arbitrary JavaScript to execute in authenticated sessions. Remote attackers can lure a logged-in user into opening a crafted URL to run injected script and take over the victim's account.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
Remediation
Upgrade Frappe ERPNext to version 14.92.1 for the 14 branch or to version 15.83.0 for the 15 branch.
Written with Claude Haiku 5.5 from the sources below · 2026-10-29
- Fix · CNA erpnext (frappe) Fixed in 14.92.1, 15.83.0
Timeline
- 2026-10-12 Threatist record created from CVE-2025-71432
- 2026-10-13 Alias added: GHSA-whfc-fq64-6jmq
- 2026-10-13 Priority changed: MEDIUM → LOW
- 2026-10-14 CISA SSVC decision points changed
References
More frappe vulnerabilities
- TI-2026-28140 ERPNext v15.103.1 and before is vulnerable to Server-Side Template Injection (SSTI). CVSS 3.1CRITICAL 9.8
- TI-2025-40873 An issue was discovered in Frappe ERPNext through 15.89.0. CVSS 3.1CRITICAL 9.8
- TI-2025-40872 An issue was discovered in Frappe ERPNext through 15.89.0. CVSS 3.1CRITICAL 9.8
- TI-2025-40871 A Server-Side Template Injection (SSTI) vulnerability exists in the Frappe ERPNext… CVSS 3.1CRITICAL 9.8
- TI-2025-32462 In Frappe ERPNext 15.57.5, the function get_rfq_containing_supplier() at… CVSS 3.1HIGH 8.2
- TI-2025-32461 In Frappe ERPNext 15.57.5, the function get_stock_balance_for() at… CVSS 3.1HIGH 8.2
Sources
- CVE-2025-71432 · CVE Program
- CVE-2025-71432 · NVD
- FIRST EPSS
- GHSA-whfc-fq64-6jmq · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences