Improper Input Validation in Metricbeat Leading to Denial of Service
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Denial of service
- Confidentiality · integrity · availability
- None · None · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-129 and the CVSS impact.
Summary
Improper Validation of Array Index (CWE-129) exists in Metricbeat can allow an attacker to cause a Denial of Service through Input Data Manipulation (CAPEC-153) via specially crafted, malformed payloads sent to the Graphite server metricset or Zookeeper server metricset. Additionally, Improper Input Validation (CWE-20) exists in the Prometheus helper module that can allow an attacker to cause a Denial of Service through Input Data Manipulation (CAPEC-153) via specially crafted, malformed metric data.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Elastic | Metricbeat | 7.0.0 – 7.17.29; 8.0.0 – 8.19.9; 9.0.0 – 9.1.9; 9.2.0 – 9.2.3 | — | No fix listed | CNA |
| — | github.com/elastic/beats/v7 (Go) | before 7.0.0-alpha2.0.20251217054608-6e42552a23ce | 7.0.0-alpha2.0.20251217054608-6e42552a23ce | Patch available | GHSA-w2gr-585j-r428 |
| — | github.com/elastic/beats/v7 (Go) | 8.0.0 to before 8.19.10 | 8.19.10 | Patch available | GHSA-w2gr-585j-r428 |
| — | github.com/elastic/beats/v7 (Go) | 9.0.0 to before 9.1.10 | 9.1.10 | Patch available | GHSA-w2gr-585j-r428 |
| — | github.com/elastic/beats/v7 (Go) | 9.2.0 to before 9.2.4 | 9.2.4 | Patch available | GHSA-w2gr-585j-r428 |
- Metricbeat VendorElastic Affected 7.0.0 – 7.17.29; 8.0.0 – 8.19.9; 9.0.0 – 9.1.9; 9.2.0 – 9.2.3 Fixed in — No fix listed CNA
- github.com/elastic/beats/v7 (Go) Vendor— Affected before 7.0.0-alpha2.0.20251217054608-6e42552a23ce Fixed in 7.0.0-alpha2.0.20251217054608-6e42552a23ce Patch available GHSA-w2gr-585j-r428
- github.com/elastic/beats/v7 (Go) Vendor— Affected 8.0.0 to before 8.19.10 Fixed in 8.19.10 Patch available GHSA-w2gr-585j-r428
- github.com/elastic/beats/v7 (Go) Vendor— Affected 9.0.0 to before 9.1.10 Fixed in 9.1.10 Patch available GHSA-w2gr-585j-r428
- github.com/elastic/beats/v7 (Go) Vendor— Affected 9.2.0 to before 9.2.4 Fixed in 9.2.4 Patch available GHSA-w2gr-585j-r428
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:elastic:kibana:*:*:*:*:*:*:*:* | 7.0.0 to before 7.17.29; 8.0.0 to before 8.19.10; 9.0.0 to before 9.1.10; 9.2.0 to before 9.2.4 | Vulnerable | Elastic |
- cpe:2.3:a:elastic:kibana:*:*:*:*:*:*:*:* Versions 7.0.0 to before 7.17.29; 8.0.0 to before 8.19.10; 9.0.0 to before 9.1.10; 9.2.0 to before 9.2.4 Vulnerable ·Elastic
Remediation
- Fix · GHSA-w2gr-585j-r428 github.com/elastic/beats/v7 (Go) Fixed in 7.0.0-alpha2.0.20251217054608-6e42552a23ce Advisory →
- Fix · GHSA-w2gr-585j-r428 github.com/elastic/beats/v7 (Go) Fixed in 8.19.10 Advisory →
- Fix · GHSA-w2gr-585j-r428 github.com/elastic/beats/v7 (Go) Fixed in 9.1.10 Advisory →
- Fix · GHSA-w2gr-585j-r428 github.com/elastic/beats/v7 (Go) Fixed in 9.2.4 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2026-0528
- 2026-10-03 Alias added: GHSA-w2gr-585j-r428
References
Advisory 2
More Elastic Kibana vulnerabilities
- TI-2019-05363 Code injection in Elastic Kibana KEVCVSS 3.1CRITICAL 10.0
- TI-2018-12328 Kibana versions before 6.4.3 and 5.6.13 contain an arbitrary file inclusion flaw in the… CVSS 3.0CRITICAL 9.8
- TI-2025-18692 Kibana arbitrary code execution via prototype pollution CVSS 3.1CRITICAL 9.8
- TI-2020-05660 Code injection in Elastic Kibana CVSS 3.1HIGH 8.8
- TI-2024-24803 Deserialization of untrusted data in Elastic Kibana CVSS 3.1CRITICAL 9.9
- TI-2024-24800 Kibana arbitrary code execution via YAML deserialization CVSS 3.1CRITICAL 9.1
Sources
- CVE-2026-0528 · CVE Program
- CVE-2026-0528 · NVD
- FIRST EPSS
- GHSA-w2gr-585j-r428 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences