Read the docs
TI-2026-00935 Aliases CVE-2026-1213GHSA-r2jv-fwfr-4j8c

Askbot 0.12.2 - Insecure Direct Object Reference (IDOR)

Priority LOW 24CWE-639Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
None
Attack complexity
Low
Attack requirements
None
Impact type
Security bypass
Confidentiality · integrity · availability
None · Low · None
Fix status
Fixed

Attack profile from CVSS 4.0 · CNA. Fix status from CNA and GitHub. Impact type from CWE-639.

Summary

All versions of askbot before and including 0.12.2 allow an attacker authenticated with normal user permissions to modify the profile picture of other application users.This issue affects askbot: 0.12.2.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00356 29th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed askbot (PyPI): 0.12.3

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
askbotaskbot0.12.2—No fix listedCNA
—askbot (PyPI)before 0.12.30.12.3Patch availableGHSA-r2jv-fwfr-4j8c
  • askbot Vendoraskbot Affected 0.12.2 Fixed in — No fix listed CNA
  • askbot (PyPI) Vendor— Affected before 0.12.3 Fixed in 0.12.3 Patch available GHSA-r2jv-fwfr-4j8c

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:askbot:askbot:*:*:*:*:*:*:*:*up to 0.12.2Vulnerableaskbot
  • cpe:2.3:a:askbot:askbot:*:*:*:*:*:*:*:* Versions up to 0.12.2 Vulnerable ·askbot

Remediation

  • Fix · GHSA-r2jv-fwfr-4j8c askbot (PyPI) Fixed in 0.12.3 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2026-1213
  2. 2026-10-03 Alias added: GHSA-r2jv-fwfr-4j8c

References

  • TI-2015-02800 Cross-site scripting (XSS) vulnerability in askbot 0.7.51-4.el6.noarch. CVSS 3.0MEDIUM 6.1
  • TI-2014-01769 Multiple cross-site scripting (XSS) vulnerabilities in Askbot before 0.7.49 allow remote… CVSS 2.0MEDIUM 4.3
  • TI-2014-01768 Cross-site scripting (XSS) vulnerability in Askbot before 0.7.49 allows remote attackers… CVSS 2.0MEDIUM 4.3

Sources