Allocation of Resources Without Limits or Throttling in GitLab
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Denial of service
- Confidentiality · integrity · availability
- None · None · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-770.
Summary
GitLab has remediated an issue in GitLab CE/EE affecting all versions from 17.1 before 18.10.7, 18.11 before 18.11.4, and 19.0 before 19.0.1 that under certain conditions could have allowed an authenticated user to cause denial of service due to insufficient validation.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| GitLab | GitLab | 17.1 to before 18.10.7; 18.11 to before 18.11.4; 19.0 to before 19.0.1 | 18.10.7, 18.11.4, 19.0.1 | Patch available | CNA |
- GitLab VendorGitLab Affected 17.1 to before 18.10.7; 18.11 to before 18.11.4; 19.0 to before 19.0.1 Fixed in 18.10.7, 18.11.4, 19.0.1 Patch available CNA
CPE configurations NVD · 6
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:gitlab:gitlab:*:*:*:*:community:*:*:* | 17.1.0 to before 18.10.7 | Vulnerable | GitLab |
| cpe:2.3:a:gitlab:gitlab:*:*:*:*:enterprise:*:*:* | 17.1.0 to before 18.10.7 | Vulnerable | GitLab |
| cpe:2.3:a:gitlab:gitlab:*:*:*:*:community:*:*:* | 18.11.0 to before 18.11.4 | Vulnerable | GitLab |
| cpe:2.3:a:gitlab:gitlab:*:*:*:*:enterprise:*:*:* | 18.11.0 to before 18.11.4 | Vulnerable | GitLab |
| cpe:2.3:a:gitlab:gitlab:19.0.0:*:*:*:community:*:*:* | 19.0.0 | Vulnerable | GitLab |
| cpe:2.3:a:gitlab:gitlab:19.0.0:*:*:*:enterprise:*:*:* | 19.0.0 | Vulnerable | GitLab |
- cpe:2.3:a:gitlab:gitlab:*:*:*:*:community:*:*:* Versions 17.1.0 to before 18.10.7 Vulnerable ·GitLab
- cpe:2.3:a:gitlab:gitlab:*:*:*:*:enterprise:*:*:* Versions 17.1.0 to before 18.10.7 Vulnerable ·GitLab
- cpe:2.3:a:gitlab:gitlab:*:*:*:*:community:*:*:* Versions 18.11.0 to before 18.11.4 Vulnerable ·GitLab
- cpe:2.3:a:gitlab:gitlab:*:*:*:*:enterprise:*:*:* Versions 18.11.0 to before 18.11.4 Vulnerable ·GitLab
- cpe:2.3:a:gitlab:gitlab:19.0.0:*:*:*:community:*:*:* Versions 19.0.0 Vulnerable ·GitLab
- cpe:2.3:a:gitlab:gitlab:19.0.0:*:*:*:enterprise:*:*:* Versions 19.0.0 Vulnerable ·GitLab
Remediation
- Fix · CNA GitLab (GitLab) Fixed in 18.10.7, 18.11.4, 19.0.1
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
GitLab 18.10.7, 18.11.4, 19.0.1
6 records Highest priority Priority MEDIUM 3 MEDIUM, 3 LOW
Other records, highest priority first
- TI-2026-05886 Incorrect Authorization in GitLabPriority MEDIUM 63
- TI-2026-02221 Missing Authorization in GitLabPriority MEDIUM 53
- TI-2026-04244 Authorization Bypass Through User-Controlled Key in GitLabPriority LOW 38
Timeline
- 2026-10-02 Threatist record created from CVE-2026-1402
- 2026-10-03 Alias added: GHSA-wgq9-qp63-g8j3
References
More Gitlab vulnerabilities
- TI-2026-71508 Integer overflow in GitLab allows code execution on the server KEVCVSS 3.1CRITICAL 10.0
- TI-2026-58817 Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal') in GitLab KEVCVSS 3.1CRITICAL 10.0
- TI-2023-06425 Weak Password Recovery Mechanism for Forgotten Password in GitLab KEVCVSS 3.1CRITICAL 10.0
- TI-2021-05191 Code injection in GitLab KEVCVSS 3.1CRITICAL 10.0
- TI-2021-05161 Server-side request forgery in GitLab KEVCVSS 3.1CRITICAL 9.8
- TI-2022-02763 Injection in GitLab CVSS 3.1CRITICAL 9.9
Sources
- CVE-2026-1402 · CVE Program
- CVE-2026-1402 · NVD
- FIRST EPSS
- GHSA-wgq9-qp63-g8j3 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences