XSS issue is Esri ArcGIS Pro versions 3.6.0 and earlier
Key facts
- Attack vector
- Local
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-79.
Summary
There is a Cross‑Site Scripting (XSS) issue in Esri ArcGIS Pro versions 3.6.0 and earlier. ArcGIS Pro is a desktop application, and exploitation is limited to local users interacting with the application; no privileged role or elevated permissions are required beyond standard local user access. A local attacker can supply malicious strings that may be rendered and executed when a specific dialog within ArcGIS Pro is opened. This issue is fixed in ArcGIS Pro version 3.6.1.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
Remediation
- Fix · CNA ArcGIS Pro (Esri) Fixed in 3.6.1
Timeline
- 2026-10-02 Threatist record created from CVE-2026-1446
- 2026-10-03 Alias added: GHSA-rwq8-4chg-7w5w
References
More Esri Arcgis Pro vulnerabilities
- TI-2021-09985 ArcGIS general raster security update: uninitialized pointer CVSS 3.1HIGH 7.8
- TI-2021-09984 ArcGIS general raster security update: buffer overflow CVSS 3.1HIGH 7.8
- TI-2021-09983 ArcGIS general raster security update: use-after-free CVSS 3.1HIGH 7.8
- TI-2025-00907 There is a code injection vulnerability in Esri ArcGIS AllSource CVSS 3.1HIGH 7.3
- TI-2025-00906 There is a code injection vulnerability in ArcGIS Pro CVSS 3.1HIGH 7.3
Sources
- CVE-2026-1446 · CVE Program
- CVE-2026-1446 · NVD
- FIRST EPSS
- GHSA-rwq8-4chg-7w5w · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences