Improper input validation in maartenbelmans Advanced Product Fields for WooCommerce
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- None · High · None
- Fix status
- No fix listed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA.
Summary
The Advanced Product Fields (Product Addons) for WooCommerce plugin for WordPress is vulnerable to Improper Input Validation in all versions up to, and including, 1.6.21. This is due to a logic flaw in the 'validate_cart_data' function. This makes it possible for unauthenticated attackers to bypass required paid addons and complete purchases at the base product price only, effectively stealing products by paying a fraction of the intended total. The vulnerability was partially patched in version 1.6.19.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| maartenbelmans | Advanced Product Fields (Product Addons) for WooCommerce | up to 1.6.21 | — | No fix listed | CNA |
- Advanced Product Fields (Product Addons) for WooCommerce Vendormaartenbelmans Affected up to 1.6.21 Fixed in — No fix listed CNA
Remediation
No fixed version listed by the sources yet.
Timeline
- 2026-10-02 Threatist record created from CVE-2026-2996
- 2026-10-03 Alias added: GHSA-9gvr-wm3r-qgg4
References
Other 4
- https://www.wordfence.com/threat-intel/vulnerabilities/id/5d9c1c3d-6882-4425-8d32-bdb57b4f133d?source=cve
- https://plugins.trac.wordpress.org/browser/advanced-product-fields-for-woocommerce/trunk/includes/controllers/class-product-controller.php#L130
- https://plugins.trac.wordpress.org/changeset/3477476/
- https://plugins.trac.wordpress.org/changeset/3483410/
More maartenbelmans vulnerabilities
- TI-2022-04562 Freemius SDK <= 2.4.2 - Missing Authorization Checks CVSS 3.1MEDIUM 6.3
- TI-2025-12725 Cross-site request forgery in maartenbelmans Advanced Product Fields for WooCommerce CVSS 3.1MEDIUM 4.3
Sources
- CVE-2026-2996 · CVE Program
- CVE-2026-2996 · NVD
- FIRST EPSS
- GHSA-9gvr-wm3r-qgg4 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences