Insufficient input validation leading to memory overread
Priority CRITICAL 99Exploited in the wildCWE-125Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- —
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA.
Summary
Insufficient input validation in NetScaler ADC and NetScaler Gateway when configured as a SAML IDP leading to memory overread
Why it matters now
Exploitation Active In CISA KEV since 2026-03-30CISA due date 2026-04-02
EPSS 0.91491 99th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed ADC (NetScaler): 66.59, 62.23, 37.262Gateway (NetScaler): 66.59, 62.23
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Active
- Automatable
- Yes
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Citrix | ADC | 14.1 to before 66.59; 13.1 to before 62.23; 13.1 FIPS and NDcPP to before 37.262 | 66.59, 62.23, 37.262 | Patch available | CNA |
| Citrix | Gateway | 14.1 to before 66.59; 13.1 to before 62.23 | 66.59, 62.23 | Patch available | CNA |
- ADC VendorCitrix Affected 14.1 to before 66.59; 13.1 to before 62.23; 13.1 FIPS and NDcPP to before 37.262 Fixed in 66.59, 62.23, 37.262 Patch available CNA
- Gateway VendorCitrix Affected 14.1 to before 66.59; 13.1 to before 62.23 Fixed in 66.59, 62.23 Patch available CNA
CPE configurations NVD · 4
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:citrix:netscaler_application_delivery_controller:*:*:*:*:fips:*:*:* | 13.1 to before 13.1-37.262 | Vulnerable | Citrix |
| cpe:2.3:a:citrix:netscaler_application_delivery_controller:*:*:*:*:ndcpp:*:*:* | 13.1 to before 13.1-37.262 | Vulnerable | Citrix |
| cpe:2.3:a:citrix:netscaler_application_delivery_controller:*:*:*:*:-:*:*:* | 13.1 to before 13.1-62.23; 14.1 to before 14.1-60.58 | Vulnerable | Citrix |
| cpe:2.3:a:citrix:netscaler_gateway:*:*:*:*:*:*:*:* | 13.1 to before 13.1-62.23; 14.1 to before 14.1-60.58 | Vulnerable | Citrix |
- cpe:2.3:a:citrix:netscaler_application_delivery_controller:*:*:*:*:fips:*:*:* Versions 13.1 to before 13.1-37.262 Vulnerable ·Citrix
- cpe:2.3:a:citrix:netscaler_application_delivery_controller:*:*:*:*:ndcpp:*:*:* Versions 13.1 to before 13.1-37.262 Vulnerable ·Citrix
- cpe:2.3:a:citrix:netscaler_application_delivery_controller:*:*:*:*:-:*:*:* Versions 13.1 to before 13.1-62.23; 14.1 to before 14.1-60.58 Vulnerable ·Citrix
- cpe:2.3:a:citrix:netscaler_gateway:*:*:*:*:*:*:*:* Versions 13.1 to before 13.1-62.23; 14.1 to before 14.1-60.58 Vulnerable ·Citrix
Remediation
- Fix · CNA ADC (NetScaler) Fixed in 66.59, 62.23, 37.262
- Fix · CNA Gateway (NetScaler) Fixed in 66.59, 62.23
Timeline
- 2026-03-30 Added to CISA KEV
- 2026-10-02 Threatist record created from CVE-2026-3055
- 2026-10-03 Alias added: GHSA-wv7p-q4p2-p6pf
- 2026-10-25 EPSS moved to the 99th percentile and above
References
More Citrix Netscaler Application Delivery Controller vulnerabilities
- TI-2026-60195 Memory overflow vulnerability leading to Remote Code Execution or Denial of Service KEVCVSS 4.0CRITICAL 9.5
- TI-2026-60194 Improper input validation in Citrix ADC KEVCVSS 4.0CRITICAL 9.5
- TI-2023-04571 Unauthenticated sensitive information disclosure in Citrix NetScaler ADC KEVCVSS 3.1CRITICAL 9.4
- TI-2023-03284 Unauthenticated remote code execution in Citrix NetScaler ADC KEVCVSS 3.1CRITICAL 9.8
- TI-2026-15872 NetScaler ADC and NetScaler Gateway Security Bulletin for CVE-2026-19490 KEVCVSS 4.0CRITICAL 9.3
- TI-2025-07100 Memory corruption in Citrix ADC KEVCVSS 4.0CRITICAL 9.2
Sources
- CVE-2026-3055 · CVE Program
- CVE-2026-3055 · NVD
- CISA Known Exploited Vulnerabilities
- FIRST EPSS
- GHSA-wv7p-q4p2-p6pf · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences