Read the docs
TI-2026-02696 Aliases CVE-2026-3119GHSA-rrrp-782c-4484

Authenticated query containing a TKEY record may cause named to terminate unexpectedly

Priority LOW 30CWE-617Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
None
Attack complexity
Low
Impact type
Denial of service
Confidentiality · integrity · availability
None · None · High
Fix status
Partial Red Hat: 1 fixed, 1 without a fix

Attack profile from CVSS 3.1 · CNA. Fix status from CNA and Red Hat. Impact type from CWE-617.

Summary

Under certain conditions, `named` may crash when processing a correctly signed query containing a TKEY record. The affected code can only be reached if an incoming request has a valid transaction signature (TSIG) from a key declared in the `named` configuration. This issue affects BIND 9 versions 9.20.0 through 9.20.20, 9.21.0 through 9.21.19, and 9.20.9-S1 through 9.20.20-S1. BIND 9 versions 9.18.0 through 9.18.46 and 9.18.11-S1 through 9.18.46-S1 are NOT affected.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00586 48th percentileScored 2026-11-07
Fix Partial BIND 9 (ISC): 9.18.0, 9.18.11-S1Red Hat: 1 advisoryRed Hat: 1 fixed, 1 without a fix

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
ISCBIND 99.20.0 – 9.20.20; 9.21.0 – 9.21.19; 9.20.9-S1 – 9.20.20-S19.18.0, 9.18.11-S1Patch availableCNA
  • BIND 9 VendorISC Affected 9.20.0 – 9.20.20; 9.21.0 – 9.21.19; 9.20.9-S1 – 9.20.20-S1 Fixed in 9.18.0, 9.18.11-S1 Patch available CNA

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:isc:bind:*:*:*:*:-:*:*:*9.20.0 to before 9.20.21; 9.21.0 to before 9.21.20VulnerableISC
  • cpe:2.3:a:isc:bind:*:*:*:*:-:*:*:* Versions 9.20.0 to before 9.20.21; 9.21.0 to before 9.21.20 Vulnerable ·ISC

Remediation

  • Fix · CNA BIND 9 (ISC) Fixed in 9.18.0, 9.18.11-S1

Red Hat 1 advisory

  • RHSA-2026:6935 Released 2026-04-07 · Red Hat rating Important
    Red Hat Hardened Images RPMs bug fix and enhancement update
    • Red Hat Hardened Images bind-9.18.48-1.hum1@aarch64, bind-9.18.48-1.hum1@src, bind-9.18.48-1.hum1@x86_64 +12

Vendor assessments

Red Hat

Red Hat rating: Moderate. Red Hat's page for this CVE →

ProductStatusPlan or fix
Red Hat Enterprise Linux 10AffectedNo fix yet: Fix deferred
Red Hat Hardened ImagesFixed RHSA-2026:6935
Not affected: 5 products
  • Red Hat Enterprise Linux 6
  • Red Hat Enterprise Linux 7
  • Red Hat Enterprise Linux 8
  • Red Hat Enterprise Linux 9
  • Red Hat OpenShift Container Platform 4

Timeline

  1. 2026-10-02 Threatist record created from CVE-2026-3119
  2. 2026-10-03 Alias added: GHSA-rrrp-782c-4484

References

  • TI-2015-04610 Assertion failure in ISC BIND named via TKEY queries KEVCVSS 3.1HIGH 7.5
  • TI-2023-27571 Certain DNSSEC aspects of the DNS protocol (in RFC 4033, 4034, 4035, 6840, and related… CVSS 3.1HIGH 7.5
  • TI-2021-07476 A second vulnerability in BIND's GSSAPI security policy negotiation can be targeted by a buffer overflow attack CVSS 3.1CRITICAL 9.8
  • TI-2023-27773 The Closest Encloser Proof aspect of the DNS protocol (in RFC 5155 when RFC 9276 guidance… CVSS 3.1HIGH 7.5
  • TI-2020-06910 A logic error in code which checks TSIG validity can be used to trigger an assertion failure in tsig.c CVSS 3.1HIGH 7.5
  • TI-2016-02320 buffer.c in named in ISC BIND 9 before 9.9.9-P3, 9.10.x before 9.10.4-P3, and 9.11.x… CVSS 3.0HIGH 7.5
See all 192 →

Sources