Amplification vulnerabilities via self-pointed glue records
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- None · None · Low
- Fix status
- Partial Red Hat: 1 fixed, 6 without a fix
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and Red Hat.
Summary
BIND resolvers are vulnerable to an amplified resource consumption/exhaustion attack. If a victim resolver makes a query to a specially crafted zone, the resolver will consume disproportionate resources. This issue affects BIND 9 versions 9.11.0 through 9.16.50, 9.18.0 through 9.18.48, 9.20.0 through 9.20.22, 9.21.0 through 9.21.21, 9.11.3-S1 through 9.16.50-S1, 9.18.11-S1 through 9.18.48-S1, and 9.20.9-S1 through 9.20.22-S1.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| ISC | BIND 9 | 9.11.0 – 9.16.50; 9.18.0 – 9.18.48; 9.20.0 – 9.20.22; 9.21.0 – 9.21.21; 9.11.3-S1 – 9.16.50-S1; 9.18.11-S1 – 9.18.48-S1; 9.20.9-S1 – 9.20.22-S1 | — | No fix listed | CNA |
- BIND 9 VendorISC Affected 9.11.0 – 9.16.50; 9.18.0 – 9.18.48; 9.20.0 – 9.20.22; 9.21.0 – 9.21.21; 9.11.3-S1 – 9.16.50-S1; 9.18.11-S1 – 9.18.48-S1; 9.20.9-S1 – 9.20.22-S1 Fixed in — No fix listed CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:isc:bind:*:*:*:*:-:*:*:* | 9.11.0 – 9.16.50; 9.18.0 to before 9.18.49; 9.20.0 to before 9.20.23; 9.21.0 to before 9.21.22 | Vulnerable | ISC |
- cpe:2.3:a:isc:bind:*:*:*:*:-:*:*:* Versions 9.11.0 – 9.16.50; 9.18.0 to before 9.18.49; 9.20.0 to before 9.20.23; 9.21.0 to before 9.21.22 Vulnerable ·ISC
Remediation
Red Hat 1 advisory
- RHSA-2026:20334 Released 2026-05-21 · Red Hat rating ImportantRed Hat Hardened Images RPMs bug fix and enhancement update
- Red Hat Hardened Images bind-9.18.49-1.hum1@aarch64, bind-9.18.49-1.hum1@src, bind-9.18.49-1.hum1@x86_64 +12
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat Enterprise Linux 10 | Affected | No fix yet |
| Red Hat Enterprise Linux 6 | Affected | No fix yet: Fix deferred |
| Red Hat Enterprise Linux 7 | Affected | No fix yet: Fix deferred |
| Red Hat Enterprise Linux 8 | Affected | No fix yet: Fix deferred |
| Red Hat Enterprise Linux 9 | Affected | No fix yet |
| Red Hat OpenShift Container Platform 4 | Affected | No fix yet: Fix deferred |
| Red Hat Hardened Images | Fixed | RHSA-2026:20334 |
Timeline
- 2026-10-02 Threatist record created from CVE-2026-3592
- 2026-10-03 Alias added: GHSA-63mj-2fw3-4w3h
References
More ISC Bind vulnerabilities
- TI-2015-04610 Assertion failure in ISC BIND named via TKEY queries KEVCVSS 3.1HIGH 7.5
- TI-2023-27571 Certain DNSSEC aspects of the DNS protocol (in RFC 4033, 4034, 4035, 6840, and related… CVSS 3.1HIGH 7.5
- TI-2021-07476 A second vulnerability in BIND's GSSAPI security policy negotiation can be targeted by a buffer overflow attack CVSS 3.1CRITICAL 9.8
- TI-2023-27773 The Closest Encloser Proof aspect of the DNS protocol (in RFC 5155 when RFC 9276 guidance… CVSS 3.1HIGH 7.5
- TI-2020-06910 A logic error in code which checks TSIG validity can be used to trigger an assertion failure in tsig.c CVSS 3.1HIGH 7.5
- TI-2016-02320 buffer.c in named in ISC BIND 9 before 9.9.9-P3, 9.10.x before 9.10.4-P3, and 9.11.x… CVSS 3.0HIGH 7.5
Sources
- CVE-2026-3592 · CVE Program
- CVE-2026-3592 · NVD
- FIRST EPSS
- GHSA-63mj-2fw3-4w3h · GitHub Advisory Database · CC BY 4.0
- CVE-2026-3592 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences