Read the docs
TI-2026-03098 Aliases CVE-2026-3593GHSA-8v2c-7qqj-7wp7

Heap use-after-free vulnerability in BIND 9 DNS-over-HTTPS implementation

Priority MEDIUM 45CWE-416Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Impact type
Code execution
Confidentiality · integrity · availability
High · High · High
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA and Red Hat. Impact type from CWE-416 and the CVSS impact.

Summary

A use-after-free vulnerability exists within the DNS-over-HTTPS implementation. This issue affects BIND 9 versions 9.20.0 through 9.20.22, 9.21.0 through 9.21.21, and 9.20.9-S1 through 9.20.22-S1. BIND 9 versions 9.18.0 through 9.18.48 and 9.18.11-S1 through 9.18.48-S1 are NOT affected.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.01538 75th percentileScored 2026-11-07
Fix Fixed BIND 9 (ISC): 9.18.0, 9.18.11-S1Red Hat: 1 advisory

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
ISCBIND 99.20.0 – 9.20.22; 9.21.0 – 9.21.21; 9.20.9-S1 – 9.20.22-S19.18.0, 9.18.11-S1Patch availableCNA
  • BIND 9 VendorISC Affected 9.20.0 – 9.20.22; 9.21.0 – 9.21.21; 9.20.9-S1 – 9.20.22-S1 Fixed in 9.18.0, 9.18.11-S1 Patch available CNA

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:isc:bind:*:*:*:*:-:*:*:*9.20.0 to before 9.20.23; 9.21.0 to before 9.21.22VulnerableISC
  • cpe:2.3:a:isc:bind:*:*:*:*:-:*:*:* Versions 9.20.0 to before 9.20.23; 9.21.0 to before 9.21.22 Vulnerable ·ISC

Remediation

  • Fix · CNA BIND 9 (ISC) Fixed in 9.18.0, 9.18.11-S1

Red Hat 1 advisory

  • RHSA-2026:7412 Released 2026-04-10 · Red Hat rating Important
    Red Hat Hardened Images RPMs bug fix and enhancement update
    • Red Hat Hardened Images bind-9.18.48-1.1.hum1@aarch64, bind-9.18.48-1.1.hum1@src, bind-9.18.48-1.1.hum1@x86_64 +12

Vendor assessments

Red Hat

Red Hat rating: Important. Red Hat's page for this CVE →

ProductStatusPlan or fix
Red Hat Hardened ImagesFixed RHSA-2026:7412
Not affected: 6 products
  • Red Hat Enterprise Linux 10
  • Red Hat Enterprise Linux 6
  • Red Hat Enterprise Linux 7
  • Red Hat Enterprise Linux 8
  • Red Hat Enterprise Linux 9
  • Red Hat OpenShift Container Platform 4

Timeline

  1. 2026-10-02 Threatist record created from CVE-2026-3593
  2. 2026-10-03 Alias added: GHSA-8v2c-7qqj-7wp7

References

  • TI-2015-04610 Assertion failure in ISC BIND named via TKEY queries KEVCVSS 3.1HIGH 7.5
  • TI-2023-27571 Certain DNSSEC aspects of the DNS protocol (in RFC 4033, 4034, 4035, 6840, and related… CVSS 3.1HIGH 7.5
  • TI-2021-07476 A second vulnerability in BIND's GSSAPI security policy negotiation can be targeted by a buffer overflow attack CVSS 3.1CRITICAL 9.8
  • TI-2023-27773 The Closest Encloser Proof aspect of the DNS protocol (in RFC 5155 when RFC 9276 guidance… CVSS 3.1HIGH 7.5
  • TI-2020-06910 A logic error in code which checks TSIG validity can be used to trigger an assertion failure in tsig.c CVSS 3.1HIGH 7.5
  • TI-2016-02320 buffer.c in named in ISC BIND 9 before 9.9.9-P3, 9.10.x before 9.10.4-P3, and 9.11.x… CVSS 3.0HIGH 7.5
See all 192 →

Sources