Stack overflow in Kea daemons
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Denial of service
- Confidentiality · integrity · availability
- None · None · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and Red Hat. Impact type from CWE-617.
Summary
Sending a maliciously crafted message to the kea-ctrl-agent, kea-dhcp-ddns, kea-dhcp4, or kea-dhcp6 daemons over any configured API socket or HA listener can cause the receiving daemon to exit with a stack overflow error. This issue affects Kea versions 2.6.0 through 2.6.4 and 3.0.0 through 3.0.2.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
Remediation
Red Hat 2 advisories
- RHSA-2026:11344 Released 2026-04-28 · Red Hat rating Importantkea security update
- Red Hat Enterprise Linux AppStream EUS (v. 10.0) kea-doc-2.6.3-2.el10_0.3, kea-hooks-2.6.3-2.el10_0.3
- Red Hat Enterprise Linux BaseOS EUS (v. 10.0) kea-2.6.3-2.el10_0.3, kea-libs-2.6.3-2.el10_0.3
- Red Hat Enterprise Linux CodeReady Linux Builder EUS (v. 10.0) kea-keama-2.6.3-2.el10_0.3
- RHSA-2026:7342 Released 2026-04-09 · Red Hat rating Importantkea security update
- Red Hat Enterprise Linux AppStream (v. 10) kea-doc-3.0.1-3.el10_1, kea-hooks-3.0.1-3.el10_1
- Red Hat Enterprise Linux BaseOS (v. 10) kea-3.0.1-3.el10_1, kea-libs-3.0.1-3.el10_1
- Red Hat Enterprise Linux CodeReady Linux Builder (v. 10) kea-keama-3.0.1-3.el10_1
Vendor assessments
Red Hat
Red Hat rating: Important. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat Enterprise Linux AppStream (v. 10) | Fixed | RHSA-2026:7342 |
| Red Hat Enterprise Linux AppStream EUS (v. 10.0) | Fixed | RHSA-2026:11344 |
| Red Hat Enterprise Linux BaseOS (v. 10) | Fixed | RHSA-2026:7342 |
| Red Hat Enterprise Linux BaseOS EUS (v. 10.0) | Fixed | RHSA-2026:11344 |
| Red Hat Enterprise Linux CodeReady Linux Builder (v. 10) | Fixed | RHSA-2026:7342 |
| Red Hat Enterprise Linux CodeReady Linux Builder EUS (v. 10.0) | Fixed | RHSA-2026:11344 |
Timeline
- 2026-10-02 Threatist record created from CVE-2026-3608
- 2026-10-03 Alias added: GHSA-8xcr-6f99-hm7w
References
More ISC vulnerabilities
- TI-2015-04610 Assertion failure in ISC BIND named via TKEY queries KEVCVSS 3.1HIGH 7.5
- TI-2023-27571 Certain DNSSEC aspects of the DNS protocol (in RFC 4033, 4034, 4035, 6840, and related… CVSS 3.1HIGH 7.5
- TI-2021-07476 A second vulnerability in BIND's GSSAPI security policy negotiation can be targeted by a buffer overflow attack CVSS 3.1CRITICAL 9.8
- TI-1999-00042 Command execution via shell metachars in INN daemon (innd) 1.5 using "newgroup" and… CVSS 3.1CRITICAL 9.8
- TI-2023-27773 The Closest Encloser Proof aspect of the DNS protocol (in RFC 5155 when RFC 9276 guidance… CVSS 3.1HIGH 7.5
- TI-2025-27240 Cache poisoning attacks with unsolicited RRs CVSS 3.1HIGH 8.6
Sources
- CVE-2026-3608 · CVE Program
- CVE-2026-3608 · NVD
- FIRST EPSS
- GHSA-8xcr-6f99-hm7w · GitHub Advisory Database · CC BY 4.0
- CVE-2026-3608 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences