HSC Cybersecurity Mailinspector URL mliUserValidation.php cross site scripting
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Passive
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- Cross-site scripting, Code execution
- Confidentiality · integrity · availability
- None · Low · None
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA. Impact type from CWE-79 and CWE-94.
Summary
A vulnerability was found in HSC Cybersecurity Mailinspector up to 5.3.2-3. Affected by this issue is some unknown functionality of the file /mailinspector/mliUserValidation.php of the component URL Handler. The manipulation of the argument error_description results in cross site scripting. The attack may be performed from remote. The exploit has been made public and could be used. Upgrading to version 5.4.0 can resolve this issue. You should upgrade the affected component. The vendor was contacted early and responded very professional: "We have already implemented the fix and made a hotfix available to affected customers, ensuring mitigation while the official release 5.4.0 has not yet been published. This allows customers to address the issue immediately, outside the regular release cycle."
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| HSC Cybersecurity | Mailinspector | 5.3.2-3 | 5.4.0 | Patch available | CNA |
- Mailinspector VendorHSC Cybersecurity Affected 5.3.2-3 Fixed in 5.4.0 Patch available CNA
Remediation
- Fix · CNA Mailinspector (HSC Cybersecurity) Fixed in 5.4.0
Timeline
- 2026-10-02 Threatist record created from CVE-2026-3610
- 2026-10-03 Alias added: GHSA-rgc7-cqpm-cvh8
References
Sources
- CVE-2026-3610 · CVE Program
- CVE-2026-3610 · NVD
- FIRST EPSS
- GHSA-rgc7-cqpm-cvh8 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences