Read the docs
TI-2026-03373 Aliases CVE-2026-3903GHSA-6qpq-j4q7-x5cr

Modular Connector <= 2.5.1 - Cross-Site Request Forgery via postConfirmOauth

Priority LOW 19CWE-352Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
Required
Attack complexity
Low
Impact type
Tampering
Confidentiality · integrity · availability
None · Low · None
Fix status
No fix listed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-352.

Summary

The Modular DS: Monitor, update, and backup multiple websites plugin for WordPress is vulnerable to Cross-Site Request Forgery in all versions up to, and including, 2.5.1. This is due to missing nonce validation on the postConfirmOauth() function. This makes it possible for unauthenticated attackers to disconnect the plugin's OAuth/SSO connection via a forged request granted they can trick a site administrator into performing an action such as clicking on a link.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00122 1st percentileScored 2026-11-07
Fix No fix listed No fixed version in the sources yet

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
Modular DSModular DS: Monitor, update, and backup multiple websitesup to 2.5.1—No fix listedCNA
  • Modular DS: Monitor, update, and backup multiple websites VendorModular DS Affected up to 2.5.1 Fixed in — No fix listed CNA

Remediation

No fixed version listed by the sources yet.

Timeline

  1. 2026-10-02 Threatist record created from CVE-2026-3903
  2. 2026-10-03 Alias added: GHSA-6qpq-j4q7-x5cr

References

  • TI-2026-18972 WordPress Modular DS plugin <= 2.5.1 - Privilege Escalation vulnerability CVSS 3.1CRITICAL 10.0

Sources