whyour qinglong API express.ts protection mechanism
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- Low · Low · Low
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA and GitHub. Impact type from CWE-693.
Summary
A security vulnerability has been detected in whyour qinglong up to 2.20.1. Affected is an unknown function of the file back/loaders/express.ts of the component API Interface. The manipulation of the argument command leads to protection mechanism failure. The attack may be initiated remotely. The exploit has been disclosed publicly and may be used. Upgrading to version 2.20.2 is able to address this issue. The identifier of the patch is 6bec52dca158481258315ba0fc2f11206df7b719. It is advisable to upgrade the affected component. The code maintainer was informed beforehand about the issues. He reacted very fast and highly professional.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| whyour | qinglong | 2.20.0; 2.20.1 | 2.20.2 | Patch available | CNA |
| — | @whyour/qinglong (npm) | before 2.20.2 | 2.20.2 | Patch available | GHSA-xj37-qjg2-xwv2 |
- qinglong Vendorwhyour Affected 2.20.0; 2.20.1 Fixed in 2.20.2 Patch available CNA
- @whyour/qinglong (npm) Vendor— Affected before 2.20.2 Fixed in 2.20.2 Patch available GHSA-xj37-qjg2-xwv2
Remediation
- Fix · CNA qinglong (whyour) Fixed in 2.20.2
- Fix · GHSA-xj37-qjg2-xwv2 @whyour/qinglong (npm) Fixed in 2.20.2 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2026-3965
- 2026-10-03 Alias added: GHSA-xj37-qjg2-xwv2
References
Patch 3
More whyour vulnerabilities
- TI-2026-40011 Qinglong: Incomplete fix for CVE-2026-3965: Improper Authentication CVSS 4.0CRITICAL 9.3
Sources
- CVE-2026-3965 · CVE Program
- CVE-2026-3965 · NVD
- FIRST EPSS
- GHSA-xj37-qjg2-xwv2 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences