Read the docs
TI-2026-03590 Aliases CVE-2026-4141GHSA-jpg5-qfwx-chrw

Quran Translations <= 1.7 - Cross-Site Request Forgery to Playlist Settings Form

Priority LOW 19CWE-352Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
Required
Attack complexity
Low
Impact type
Tampering
Confidentiality · integrity · availability
None · Low · None
Fix status
No fix listed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-352.

Summary

The Quran Translations plugin for WordPress is vulnerable to Cross-Site Request Forgery in all versions up to, and including, 1.7. This is due to missing nonce validation in the quran_playlist_options() function that handles the plugin's settings page. The function processes POST requests to update plugin options via update_option() without any wp_nonce_field() in the form or wp_verify_nonce()/check_admin_referer() verification before processing. This makes it possible for unauthenticated attackers to modify plugin settings (toggling display options for PDF, RSS, podcast, media player links, playlist title, and playlist code) via a forged request granted they can trick a site administrator into performing an action such as clicking on a link.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00166 5th percentileScored 2026-11-07
Fix No fix listed No fixed version in the sources yet

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
edckwtQuran Translationsup to 1.7—No fix listedCNA
  • Quran Translations Vendoredckwt Affected up to 1.7 Fixed in — No fix listed CNA

Remediation

No fixed version listed by the sources yet.

Timeline

  1. 2026-10-02 Threatist record created from CVE-2026-4141
  2. 2026-10-03 Alias added: GHSA-jpg5-qfwx-chrw

References

  • TI-2024-34539 WordPress Quran Shortcode plugin <= 1.5 - SQL Injection vulnerability CVSS 3.1HIGH 8.5
  • TI-2025-12944 Quran Gateway <= 1.5 - Cross-Site Request Forgery to Settings Update CVSS 3.1MEDIUM 4.3

Sources