Open5GS CCA smf_s6b_sta_cb denial of service
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- Denial of service
- Confidentiality · integrity · availability
- None · None · Low
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA. Impact type from CWE-404.
Summary
A vulnerability was determined in Open5GS up to 2.7.6. The affected element is the function smf_gx_cca_cb/smf_gy_cca_cb/smf_s6b_aaa_cb/smf_s6b_sta_cb of the component CCA Handler. This manipulation causes denial of service. The attack can be initiated remotely. The exploit has been publicly disclosed and may be utilized. Upgrading to version 2.7.7 is sufficient to fix this issue. Patch name: 80eb484a6ab32968e755e628b70d1a9c64f012ec. Upgrading the affected component is recommended.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- Yes
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | Open5GS | 2.7.0; 2.7.1; 2.7.2; 2.7.3; 2.7.4; 2.7.5; 2.7.6 | 2.7.7 | Patch available | CNA |
- Open5GS Vendor— Affected 2.7.0; 2.7.1; 2.7.2; 2.7.3; 2.7.4; 2.7.5; 2.7.6 Fixed in 2.7.7 Patch available CNA
Remediation
- Fix · CNA Open5GS Fixed in 2.7.7
Timeline
- 2026-10-02 Threatist record created from CVE-2026-4240
- 2026-10-03 Alias added: GHSA-wq9j-47c8-8fpr
- 2026-10-25 EPSS moved to the below the 50th percentile
References
Patch 2
More Open5gs vulnerabilities
- TI-2024-26883 open5gs v2.6.4 is vulnerable to Buffer Overflow. CVSS 3.1CRITICAL 9.8
- TI-2024-26882 Open5GS v2.6.4 is vulnerable to Buffer Overflow. CVSS 3.1CRITICAL 9.8
- TI-2024-22649 Open5GS MME versions <= 2.6.4 contains an assertion that can be remotely triggered via a… CVSS 3.1HIGH 8.6
- TI-2023-18757 Open5GS MME versions <= 2.6.4 contain a reachable assertion in the `Uplink NAS Transport`… CVSS 3.1HIGH 8.6
- TI-2023-18755 Open5GS MME version <= 2.6.4 contains an assertion that can be remotely triggered via a… CVSS 3.1HIGH 8.6
- TI-2023-18754 Open5GS MME versions <= 2.6.4 contain an assertion that can be remotely triggered via a… CVSS 3.1HIGH 8.6
Sources
- CVE-2026-4240 · CVE Program
- CVE-2026-4240 · NVD
- FIRST EPSS
- GHSA-wq9j-47c8-8fpr · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences