Libsoup: libsoup: denial of service via use-after-free in http/2 server
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Denial of service
- Confidentiality · integrity · availability
- None · None · High
- Fix status
- Partial Red Hat: 4 fixed, 1 without a fix
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and Red Hat. Impact type from CWE-416 and the CVSS impact.
Summary
A flaw was found in libsoup, a library for handling HTTP requests. This vulnerability, known as a Use-After-Free, occurs in the HTTP/2 server implementation. A remote attacker can exploit this by sending specially crafted HTTP/2 requests that cause authentication failures. This can lead to the application attempting to access memory that has already been freed, potentially causing application instability or crashes, resulting in a Denial of Service (DoS).
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- Yes
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Red Hat | Red Hat Enterprise Linux 10 | — | 3.6.5-3.el10_1.11 | Patch available | CNA |
| Red Hat | Red Hat Enterprise Linux 10 | — | 3.6.5-3.el10_2.11 | Patch available | CNA |
| Red Hat | Red Hat Enterprise Linux 10.0 Extended Update Support | — | 3.6.5-3.el10_0.15 | Patch available | CNA |
| Red Hat | Red Hat Enterprise Linux 6 | — | — | No fix listed | CNA |
| Red Hat | Red Hat Enterprise Linux 7 | — | — | Not affected | CNA |
| Red Hat | Red Hat Enterprise Linux 8 | — | — | Not affected | CNA |
| Red Hat | Red Hat Enterprise Linux 9 | — | — | Not affected | CNA |
- Red Hat Enterprise Linux 10 VendorRed Hat Affected — Fixed in 3.6.5-3.el10_1.11 Patch available CNA
- Red Hat Enterprise Linux 10 VendorRed Hat Affected — Fixed in 3.6.5-3.el10_2.11 Patch available CNA
- Red Hat Enterprise Linux 10.0 Extended Update Support VendorRed Hat Affected — Fixed in 3.6.5-3.el10_0.15 Patch available CNA
- Red Hat Enterprise Linux 6 VendorRed Hat Affected — Fixed in — No fix listed CNA
- Red Hat Enterprise Linux 7 VendorRed Hat Affected — Fixed in — Not affected CNA
- Red Hat Enterprise Linux 8 VendorRed Hat Affected — Fixed in — Not affected CNA
- Red Hat Enterprise Linux 9 VendorRed Hat Affected — Fixed in — Not affected CNA
CPE configurations NVD · 6
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:gnome:libsoup:-:*:*:*:*:*:*:* | not specified by NVD | Vulnerable | GNOME |
| cpe:2.3:o:redhat:enterprise_linux:6.0:*:*:*:*:*:*:* | 6.0 | Vulnerable | Red Hat |
| cpe:2.3:o:redhat:enterprise_linux:7.0:*:*:*:*:*:*:* | 7.0 | Vulnerable | Red Hat |
| cpe:2.3:o:redhat:enterprise_linux:8.0:*:*:*:*:*:*:* | 8.0 | Vulnerable | Red Hat |
| cpe:2.3:o:redhat:enterprise_linux:9.0:*:*:*:*:*:*:* | 9.0 | Vulnerable | Red Hat |
| cpe:2.3:o:redhat:enterprise_linux:10.0:*:*:*:*:*:*:* | 10.0 | Vulnerable | Red Hat |
- cpe:2.3:a:gnome:libsoup:-:*:*:*:*:*:*:* Versions not specified by NVD Vulnerable ·GNOME
- cpe:2.3:o:redhat:enterprise_linux:6.0:*:*:*:*:*:*:* Versions 6.0 Vulnerable ·Red Hat
- cpe:2.3:o:redhat:enterprise_linux:7.0:*:*:*:*:*:*:* Versions 7.0 Vulnerable ·Red Hat
- cpe:2.3:o:redhat:enterprise_linux:8.0:*:*:*:*:*:*:* Versions 8.0 Vulnerable ·Red Hat
- cpe:2.3:o:redhat:enterprise_linux:9.0:*:*:*:*:*:*:* Versions 9.0 Vulnerable ·Red Hat
- cpe:2.3:o:redhat:enterprise_linux:10.0:*:*:*:*:*:*:* Versions 10.0 Vulnerable ·Red Hat
Remediation
Red Hat 3 advisories
- RHSA-2026:19143 Released 2026-05-19 · Red Hat rating Moderatelibsoup3 security update
- Red Hat Enterprise Linux AppStream (v. 10) libsoup3-3.6.5-3.el10_2.11, libsoup3-devel-3.6.5-3.el10_2.11
- Red Hat Enterprise Linux CodeReady Linux Builder (v. 10) libsoup3-doc-3.6.5-3.el10_2.11
- RHSA-2026:17482 Released 2026-05-14 · Red Hat rating Moderatelibsoup3 security update
- Red Hat Enterprise Linux AppStream EUS (v. 10.0) libsoup3-3.6.5-3.el10_0.15, libsoup3-devel-3.6.5-3.el10_0.15
- Red Hat Enterprise Linux CodeReady Linux Builder EUS (v. 10.0) libsoup3-doc-3.6.5-3.el10_0.15
- RHSA-2026:15968 Released 2026-05-11 · Red Hat rating Moderatelibsoup3 security update
- Red Hat Enterprise Linux AppStream (v. 10) libsoup3-3.6.5-3.el10_1.11, libsoup3-devel-3.6.5-3.el10_1.11
- Red Hat Enterprise Linux CodeReady Linux Builder (v. 10) libsoup3-doc-3.6.5-3.el10_1.11
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat Enterprise Linux 6 | Affected | No fix planned: Will not fix |
| Red Hat Enterprise Linux AppStream (v. 10) | Fixed | RHSA-2026:15968, RHSA-2026:19143 |
| Red Hat Enterprise Linux AppStream EUS (v. 10.0) | Fixed | RHSA-2026:17482 |
| Red Hat Enterprise Linux CodeReady Linux Builder (v. 10) | Fixed | RHSA-2026:15968, RHSA-2026:19143 |
| Red Hat Enterprise Linux CodeReady Linux Builder EUS (v. 10.0) | Fixed | RHSA-2026:17482 |
Not affected: 3 products
- Red Hat Enterprise Linux 7
- Red Hat Enterprise Linux 8
- Red Hat Enterprise Linux 9
Timeline
- 2026-10-02 Threatist record created from CVE-2026-4271
- 2026-10-03 Alias added: GHSA-xxmc-fm3p-q3x8
References
More Red Hat Enterprise Linux vulnerabilities
- TI-2019-08259 Underflow in PHP-FPM can lead to RCE KEVCVSS 3.1CRITICAL 9.8
- TI-2018-10530 Code injection in [UNKNOWN] RichFaces KEVCVSS 3.1CRITICAL 9.8
- TI-2014-05975 GNU Bash through 4.3 bash43-025 processes trailing strings after certain malformed… KEVCVSS 3.1CRITICAL 9.8
- TI-2014-05157 GNU Bash through 4.3 processes trailing strings after function definitions in the values… KEVCVSS 3.1CRITICAL 9.8
- TI-2025-23530 Sudo before 1.9.17p1 allows local users to obtain root access because /etc/nsswitch.conf… KEVCVSS 3.1CRITICAL 9.3
- TI-2021-17490 mod_proxy SSRF KEVCVSS 3.1CRITICAL 9.0
Sources
- CVE-2026-4271 · CVE Program
- CVE-2026-4271 · NVD
- FIRST EPSS
- GHSA-xxmc-fm3p-q3x8 · GitHub Advisory Database · CC BY 4.0
- CVE-2026-4271 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences