Privilege abuse in ModelAdmin.list_editable
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- None · Low · None
- Fix status
- Partial Red Hat: 3 without a fix
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-862.
Summary
An issue was discovered in 6.0 before 6.0.4, 5.2 before 5.2.13, and 4.2 before 4.2.30. Admin changelist forms using `ModelAdmin.list_editable` incorrectly allowed new instances to be created via forged `POST` data. Earlier, unsupported Django series (such as 5.0.x, 4.1.x, and 3.2.x) were not evaluated and may also be affected. Django would like to thank Cantina for reporting this issue.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| djangoproject | Django | 6.0 to before 6.0.4; 5.2 to before 5.2.13; 4.2 to before 4.2.30 | 6.0.4, 5.2.13, 4.2.30 | Patch available | CNA |
| — | Django (PyPI) | 6.0 to before 6.0.4 | 6.0.4 | Patch available | GHSA-mmwr-2jhp-mc7j |
| — | Django (PyPI) | 5.2 to before 5.2.13 | 5.2.13 | Patch available | GHSA-mmwr-2jhp-mc7j |
| — | Django (PyPI) | 4.2 to before 4.2.30 | 4.2.30 | Patch available | GHSA-mmwr-2jhp-mc7j |
- Django Vendordjangoproject Affected 6.0 to before 6.0.4; 5.2 to before 5.2.13; 4.2 to before 4.2.30 Fixed in 6.0.4, 5.2.13, 4.2.30 Patch available CNA
- Django (PyPI) Vendor— Affected 6.0 to before 6.0.4 Fixed in 6.0.4 Patch available GHSA-mmwr-2jhp-mc7j
- Django (PyPI) Vendor— Affected 5.2 to before 5.2.13 Fixed in 5.2.13 Patch available GHSA-mmwr-2jhp-mc7j
- Django (PyPI) Vendor— Affected 4.2 to before 4.2.30 Fixed in 4.2.30 Patch available GHSA-mmwr-2jhp-mc7j
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:djangoproject:django:*:*:*:*:*:*:*:* | 4.2 to before 4.2.30; 5.2 to before 5.2.13; 6.0 to before 6.0.4 | Vulnerable | djangoproject |
- cpe:2.3:a:djangoproject:django:*:*:*:*:*:*:*:* Versions 4.2 to before 4.2.30; 5.2 to before 5.2.13; 6.0 to before 6.0.4 Vulnerable ·djangoproject
Remediation
- Fix · CNA Django (djangoproject) Fixed in 6.0.4, 5.2.13, 4.2.30
- Fix · GHSA-mmwr-2jhp-mc7j Django (PyPI) Fixed in 6.0.4 Advisory →
- Fix · GHSA-mmwr-2jhp-mc7j Django (PyPI) Fixed in 5.2.13 Advisory →
- Fix · GHSA-mmwr-2jhp-mc7j Django (PyPI) Fixed in 4.2.30 Advisory →
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Advisory ·
djangoproject Django — Django security releases issued: 6.0.4, 5.2.13, and 4.2.30
5 records Highest priority Priority MEDIUM 2 MEDIUM, 3 LOW
Other records, highest priority first
- TI-2026-03722 Privilege abuse in GenericInlineModelAdminPriority MEDIUM 49
- TI-2026-25480 Potential denial-of-service vulnerability in ASGI requests via memory upload limit bypassPriority MEDIUM 40
- TI-2026-03372 ASGI header spoofing via underscore/hyphen conflationPriority LOW 39
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat Ansible Automation Platform 2 | Affected | No fix yet: Fix deferred |
| Red Hat Discovery 2 | Affected | No fix yet: Fix deferred |
| Red Hat Satellite 6 | Affected | No fix yet: Fix deferred |
Timeline
- 2026-10-02 Threatist record created from CVE-2026-4292
- 2026-10-03 Alias added: GHSA-mmwr-2jhp-mc7j
References
More djangoproject Django vulnerabilities
- TI-2022-15177 An issue was discovered in Django 3.2 before 3.2.14 and 4.0 before 4.0.6. CVSS 3.1CRITICAL 9.8
- TI-2020-05994 Django 1.11 before 1.11.28, 2.2 before 2.2.10, and 3.0 before 3.0.3 allows SQL Injection… CVSS 3.1CRITICAL 9.8
- TI-2023-10198 An issue was discovered in the Multipart Request Parser in Django 3.2 before 3.2.18, 4.0… CVSS 3.1HIGH 7.5
- TI-2019-14306 Django before 1.11.27, 2.x before 2.2.9, and 3.x before 3.0.1 allows account takeover. CVSS 3.1CRITICAL 9.8
- TI-2019-10595 An issue was discovered in Django 1.11.x before 1.11.23, 2.1.x before 2.1.11, and 2.2.x… CVSS 3.0CRITICAL 9.8
- TI-2021-14006 Django 3.1.x before 3.1.13 and 3.2.x before 3.2.5 allows QuerySet.order_by SQL injection… CVSS 3.1CRITICAL 9.8
Sources
- CVE-2026-4292 · CVE Program
- CVE-2026-4292 · NVD
- FIRST EPSS
- GHSA-mmwr-2jhp-mc7j · GitHub Advisory Database · CC BY 4.0
- CVE-2026-4292 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences