Exposed Dangerous Method or Function in GitLab
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA.
Summary
GitLab has remediated an issue in GitLab CE/EE affecting all versions from 16.9.6 before 18.8.9, 18.9 before 18.9.5, and 18.10 before 18.10.3 that could have allowed an authenticated user to invoke unintended server-side methods through websocket connections due to improper access control.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| GitLab | GitLab | 16.9.6 to before 18.8.9; 18.9 to before 18.9.5; 18.10 to before 18.10.3 | 18.8.9, 18.9.5, 18.10.3 | Patch available | CNA |
- GitLab VendorGitLab Affected 16.9.6 to before 18.8.9; 18.9 to before 18.9.5; 18.10 to before 18.10.3 Fixed in 18.8.9, 18.9.5, 18.10.3 Patch available CNA
CPE configurations NVD · 2
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:gitlab:gitlab:*:*:*:*:enterprise:*:*:* | 16.9.6 to before 18.8.9; 18.9.0 to before 18.9.5; 18.10.0 to before 18.10.3 | Vulnerable | GitLab |
| cpe:2.3:a:gitlab:gitlab:*:*:*:*:community:*:*:* | 16.9.6 to before 18.8.9; 18.9.0 to before 18.9.5; 18.10.0 to before 18.10.3 | Vulnerable | GitLab |
- cpe:2.3:a:gitlab:gitlab:*:*:*:*:enterprise:*:*:* Versions 16.9.6 to before 18.8.9; 18.9.0 to before 18.9.5; 18.10.0 to before 18.10.3 Vulnerable ·GitLab
- cpe:2.3:a:gitlab:gitlab:*:*:*:*:community:*:*:* Versions 16.9.6 to before 18.8.9; 18.9.0 to before 18.9.5; 18.10.0 to before 18.10.3 Vulnerable ·GitLab
Remediation
- Fix · CNA GitLab (GitLab) Fixed in 18.8.9, 18.9.5, 18.10.3
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
GitLab 18.10.3, 18.8.9, 18.9.5
11 records Highest priority Priority HIGH 1 HIGH, 2 MEDIUM, 8 LOW
Other records, highest priority first
- TI-2026-00822 Improper Validation of Specified Quantity in Input in GitLabPriority HIGH 72
- TI-2026-01435 Incorrect Authorization in GitLabPriority MEDIUM 53
- TI-2025-11616 Improper Validation of Specified Quantity in Input in GitLabPriority MEDIUM 40
Timeline
- 2026-10-02 Threatist record created from CVE-2026-5173
- 2026-10-03 Alias added: GHSA-5gj7-3j23-w2h2
References
More Gitlab vulnerabilities
- TI-2026-71508 Integer overflow in GitLab allows code execution on the server KEVCVSS 3.1CRITICAL 10.0
- TI-2026-58817 Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal') in GitLab KEVCVSS 3.1CRITICAL 10.0
- TI-2023-06425 Weak Password Recovery Mechanism for Forgotten Password in GitLab KEVCVSS 3.1CRITICAL 10.0
- TI-2021-05191 Code injection in GitLab KEVCVSS 3.1CRITICAL 10.0
- TI-2021-05161 Server-side request forgery in GitLab KEVCVSS 3.1CRITICAL 9.8
- TI-2022-02763 Injection in GitLab CVSS 3.1CRITICAL 9.9
Sources
- CVE-2026-5173 · CVE Program
- CVE-2026-5173 · NVD
- FIRST EPSS
- GHSA-5gj7-3j23-w2h2 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences