Out-of-bounds Write in Firecracker virtio-pci Transport
Key facts
- Attack vector
- Local
- Privileges required
- High
- User interaction
- None
- Attack complexity
- High
- Attack requirements
- Present
- Impact type
- Denial of service, Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA. Impact type from CWE-369, CWE-787 and the CVSS impact.
Summary
An out-of-bounds write issue in the virtio PCI transport in Firecracker 1.13.0 through 1.14.3 and 1.15.0 on x86_64 and aarch64 might allow a local guest user with root privileges to crash the Firecracker VMM process or potentially execute arbitrary code on the host via modification of virtio queue configuration registers after device activation. Achieving code execution on the host requires additional preconditions, such as the use of a custom guest kernel or specific snapshot configurations. To remediate this, users should upgrade to Firecracker 1.14.4 or 1.15.1 and later.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| AWS | Firecracker | 1.13.0 – 1.14.3; 1.15.0 | 1.14.4, 1.15.1 | Patch available | CNA |
- Firecracker VendorAWS Affected 1.13.0 – 1.14.3; 1.15.0 Fixed in 1.14.4, 1.15.1 Patch available CNA
Remediation
- Fix · CNA Firecracker (AWS) Fixed in 1.14.4, 1.15.1
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2026-5747
References
Patch 2
More AWS Firecracker vulnerabilities
- TI-2019-13671 Firecracker vsock implementation buffer overflow in versions 0.18.0 and 0.19.0. CVSS 3.1CRITICAL 9.8
- TI-2020-16517 In Amazon AWS Firecracker before 0.21.3, and 0.22.x before 0.22.1, the serial console… CVSS 3.1HIGH 7.5
- TI-2020-12848 In Firecracker 0.20.x before 0.20.1 and 0.21.x before 0.21.2, the network stack can… CVSS 3.1MEDIUM 5.9
- TI-2026-01085 Arbitrary Host File Overwrite via Symlink in Firecracker Jailer CVSS 4.0MEDIUM 6.0
Sources
- CVE-2026-5747 · CVE Program
- CVE-2026-5747 · NVD
- FIRST EPSS
- CVE-2026-5747 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences