FoundationAgents MetaGPT terminal.py Terminal.run_command os command injection
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- Code execution
- Confidentiality · integrity · availability
- Low · Low · Low
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA and GitHub. Impact type from CWE-77.
Summary
A vulnerability has been found in FoundationAgents MetaGPT up to 0.8.1. This issue affects the function Terminal.run_command in the library metagpt/tools/libs/terminal.py. The manipulation leads to os command injection. Remote exploitation of the attack is possible. The exploit has been disclosed to the public and may be used. The identifier of the patch is d04ffc8dc67903e8b327f78ec121df5e190ffc7b. Applying a patch is the recommended action to fix this issue.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- Yes
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| FoundationAgents | MetaGPT | 0.8.0; 0.8.1 | — | No fix listed | CNA |
| — | metagpt (PyPI) | before 0.8.2 | 0.8.2 | Patch available | GHSA-wp29-qmvj-frvp |
- MetaGPT VendorFoundationAgents Affected 0.8.0; 0.8.1 Fixed in — No fix listed CNA
- metagpt (PyPI) Vendor— Affected before 0.8.2 Fixed in 0.8.2 Patch available GHSA-wp29-qmvj-frvp
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:deepwisdom:metagpt:*:*:*:*:*:*:*:* | up to 0.8.1 | Vulnerable | FoundationAgents |
- cpe:2.3:a:deepwisdom:metagpt:*:*:*:*:*:*:*:* Versions up to 0.8.1 Vulnerable ·FoundationAgents
Remediation
- Fix · GHSA-wp29-qmvj-frvp metagpt (PyPI) Fixed in 0.8.2 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2026-5972
- 2026-10-03 Alias added: GHSA-wp29-qmvj-frvp
References
More FoundationAgents Metagpt vulnerabilities
- TI-2024-15753 MetaGPT through 0.6.4 allows the QaEngineer role to execute arbitrary code because… CVSS 3.1HIGH 8.8
- TI-2026-05354 FoundationAgents MetaGPT Tree-of-Thought Solver tot.py generate_thoughts code injection CVSS 4.0MEDIUM 6.9
- TI-2026-05237 FoundationAgents MetaGPT terminal.py Bash.run os command injection CVSS 4.0MEDIUM 6.9
- TI-2026-05236 FoundationAgents MetaGPT common.py get_mime_type os command injection CVSS 4.0MEDIUM 6.9
- TI-2026-05234 FoundationAgents MetaGPT XML action_node.py ActionNode.xml_fill eval injection CVSS 4.0MEDIUM 6.9
- TI-2026-05233 FoundationAgents MetaGPT HumanEvalBenchmark/MBPPBenchmark check_solution code injection CVSS 4.0MEDIUM 6.9
Sources
- CVE-2026-5972 · CVE Program
- CVE-2026-5972 · NVD
- FIRST EPSS
- GHSA-wp29-qmvj-frvp · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences