AWS EFS CSI Driver Mount Option Injection
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- None
- Attack complexity
- Low
- Attack requirements
- Present
- Impact type
- Code execution
- Confidentiality · integrity · availability
- None · High · None
- Fix status
- Partial Red Hat: 1 without a fix
Attack profile from CVSS 4.0 · CNA. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-88.
Summary
Improper neutralization of argument delimiters in the volume handling component in AWS EFS CSI Driver (aws-efs-csi-driver) before v3.0.1 allows remote authenticated users with PersistentVolume creation permissions to inject arbitrary mount options via comma injection. To remediate this issue, users should upgrade to version v3.0.1
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| AWS | AWS EFS CSI Driver | before 3.0.1 | 3.0.1 | Patch available | CNA |
| — | github.com/kubernetes-sigs/aws-efs-csi-driver (Go) | before 1.7.8-0.20260416142831-51806c22c575 | 1.7.8-0.20260416142831-51806c22c575 | Patch available | GHSA-mph4-q2vm-w2pw |
- AWS EFS CSI Driver VendorAWS Affected before 3.0.1 Fixed in 3.0.1 Patch available CNA
- github.com/kubernetes-sigs/aws-efs-csi-driver (Go) Vendor— Affected before 1.7.8-0.20260416142831-51806c22c575 Fixed in 1.7.8-0.20260416142831-51806c22c575 Patch available GHSA-mph4-q2vm-w2pw
Remediation
- Fix · CNA AWS EFS CSI Driver (Amazon) Fixed in 3.0.1
- Fix · GHSA-mph4-q2vm-w2pw github.com/kubernetes-sigs/aws-efs-csi-driver (Go) Fixed in 1.7.8-0.20260416142831-51806c22c575 Advisory →
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat OpenShift Container Platform 4 | Affected | No fix yet: Fix deferred |
Timeline
- 2026-10-02 Threatist record created from CVE-2026-6437
- 2026-10-03 Alias added: GHSA-mph4-q2vm-w2pw
- 2026-10-20 Affected versions changed · CNA
- 2026-10-25 EPSS moved to the below the 50th percentile
References
Advisory 3
Sources
- CVE-2026-6437 · CVE Program
- CVE-2026-6437 · NVD
- FIRST EPSS
- GHSA-mph4-q2vm-w2pw · GitHub Advisory Database · CC BY 4.0
- CVE-2026-6437 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences