Potential exposure of private data due to incorrect handling of Vary: * in UpdateCacheMiddleware
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Passive
- Attack complexity
- Low
- Attack requirements
- Present
- Impact type
- —
- Confidentiality · integrity · availability
- Low · None · None
- Fix status
- Partial Red Hat: 8 without a fix
Attack profile from CVSS 4.0 · CNA. Fix status from CNA, GitHub and Red Hat.
Summary
An issue was discovered in 6.0 before 6.0.5 and 5.2 before 5.2.14. `django.middleware.cache.UpdateCacheMiddleware` erroneously caches requests where the `Vary` header contained an asterisk (`'*'`). This can lead to private data being stored and served. Earlier, unsupported Django series (such as 5.0.x, 4.1.x, and 3.2.x) were not evaluated and may also be affected. Django would like to thank Ahmad Sadeddin for reporting this issue.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| djangoproject | Django | 6.0 to before 6.0.5; 5.2 to before 5.2.14 | 6.0.5, 5.2.14 | Patch available | CNA |
| — | Django (PyPI) | 6.0 to before 6.0.5 | 6.0.5 | Patch available | GHSA-5hrc-gvxj-w55p |
| — | Django (PyPI) | 5.2 to before 5.2.14 | 5.2.14 | Patch available | GHSA-5hrc-gvxj-w55p |
- Django Vendordjangoproject Affected 6.0 to before 6.0.5; 5.2 to before 5.2.14 Fixed in 6.0.5, 5.2.14 Patch available CNA
- Django (PyPI) Vendor— Affected 6.0 to before 6.0.5 Fixed in 6.0.5 Patch available GHSA-5hrc-gvxj-w55p
- Django (PyPI) Vendor— Affected 5.2 to before 5.2.14 Fixed in 5.2.14 Patch available GHSA-5hrc-gvxj-w55p
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:djangoproject:django:*:*:*:*:*:*:*:* | 5.2 to before 5.2.14; 6.0 to before 6.0.5 | Vulnerable | djangoproject |
- cpe:2.3:a:djangoproject:django:*:*:*:*:*:*:*:* Versions 5.2 to before 5.2.14; 6.0 to before 6.0.5 Vulnerable ·djangoproject
Remediation
- Fix · CNA Django (djangoproject) Fixed in 6.0.5, 5.2.14
- Fix · GHSA-5hrc-gvxj-w55p Django (PyPI) Fixed in 6.0.5 Advisory →
- Fix · GHSA-5hrc-gvxj-w55p Django (PyPI) Fixed in 5.2.14 Advisory →
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Advisory ·
djangoproject Django — Django security releases issued: 6.0.5 and 5.2.14
3 records Highest priority Priority LOW 3 LOW
Other records, highest priority first
- TI-2026-05052 Potential denial-of-service vulnerability in ASGI requests via file upload limit bypassPriority LOW 28
- TI-2026-27345 Session fixation via public cached pages and SESSION_SAVE_EVERY_REQUESTPriority LOW 13
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat Ansible Automation Platform 2 | Affected | No fix yet: Fix deferred |
| Red Hat Discovery 2 | Affected | No fix yet: Fix deferred |
| Red Hat OpenStack Platform 16.2 | Affected | No fix yet: Fix deferred |
| Red Hat OpenStack Platform 17.1 | Affected | No fix yet: Fix deferred |
| Red Hat OpenStack Platform 18.0 | Affected | No fix yet: Fix deferred |
| Red Hat Satellite 6 | Affected | No fix yet: Fix deferred |
| Red Hat Update Infrastructure 4 for Cloud Providers | Affected | No fix yet: Fix deferred |
| Self-service automation portal 2 | Affected | — |
Timeline
- 2026-10-02 Threatist record created from CVE-2026-6907
- 2026-10-03 Alias added: GHSA-5hrc-gvxj-w55p
References
Advisory 4
More djangoproject Django vulnerabilities
- TI-2022-15177 An issue was discovered in Django 3.2 before 3.2.14 and 4.0 before 4.0.6. CVSS 3.1CRITICAL 9.8
- TI-2020-05994 Django 1.11 before 1.11.28, 2.2 before 2.2.10, and 3.0 before 3.0.3 allows SQL Injection… CVSS 3.1CRITICAL 9.8
- TI-2023-10198 An issue was discovered in the Multipart Request Parser in Django 3.2 before 3.2.18, 4.0… CVSS 3.1HIGH 7.5
- TI-2019-14306 Django before 1.11.27, 2.x before 2.2.9, and 3.x before 3.0.1 allows account takeover. CVSS 3.1CRITICAL 9.8
- TI-2019-10595 An issue was discovered in Django 1.11.x before 1.11.23, 2.1.x before 2.1.11, and 2.2.x… CVSS 3.0CRITICAL 9.8
- TI-2021-14006 Django 3.1.x before 3.1.13 and 3.2.x before 3.2.5 allows QuerySet.order_by SQL injection… CVSS 3.1CRITICAL 9.8
Sources
- CVE-2026-6907 · CVE Program
- CVE-2026-6907 · NVD
- FIRST EPSS
- GHSA-5hrc-gvxj-w55p · GitHub Advisory Database · CC BY 4.0
- CVE-2026-6907 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences