osrg GoBGP mrt.go parseRibEntry integer underflow
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- —
- Confidentiality · integrity · availability
- Low · Low · Low
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA and GitHub.
Summary
A vulnerability was determined in osrg GoBGP up to 4.3.0. Affected by this vulnerability is the function parseRibEntry of the file pkg/packet/mrt/mrt.go. Executing a manipulation can lead to integer underflow. It is possible to launch the attack remotely. Upgrading to version 4.4.0 addresses this issue. This patch is called 76d911046344a3923cbe573364197aa081944592. It is suggested to upgrade the affected component.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| osrg | GoBGP | 4.0; 4.1; 4.2; 4.3.0 | 4.4.0 | Patch available | CNA |
| — | github.com/osrg/gobgp/v4 (Go) | before 4.4.0 | 4.4.0 | Patch available | GHSA-hj4w-qr9j-c4cf |
- GoBGP Vendorosrg Affected 4.0; 4.1; 4.2; 4.3.0 Fixed in 4.4.0 Patch available CNA
- github.com/osrg/gobgp/v4 (Go) Vendor— Affected before 4.4.0 Fixed in 4.4.0 Patch available GHSA-hj4w-qr9j-c4cf
Remediation
- Fix · CNA GoBGP (osrg) Fixed in 4.4.0
- Fix · GHSA-hj4w-qr9j-c4cf github.com/osrg/gobgp/v4 (Go) Fixed in 4.4.0 Advisory →
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2026-7736
- 2026-10-03 Alias added: GHSA-hj4w-qr9j-c4cf
References
More osrg Gobgp vulnerabilities
- TI-2026-30596 GoBGP: Panic in AdjRib.Update via malformed BGP Update message (Nil Pointer Dereference) CVSS 3.1HIGH 7.5
- TI-2026-30162 GoBGP: Remote Denial of Service (Panic) in UpdatePathAttrs4ByteAs via Malformed BGP UPDATE CVSS 3.1HIGH 7.5
- TI-2026-30161 GoBGP: Remote Denial of Service (Panic) via Malformed Well-known Path Attribute CVSS 3.1HIGH 7.5
- TI-2026-23526 An issue in GoBGP gobgpd v.4.2.0 allows a remote attacker to cause a denial of service via the NEXT_HOP path attribute CVSS 3.1HIGH 7.5
- TI-2025-28529 An issue was discovered in GoBGP before 3.35.0. CVSS 3.1HIGH 8.6
- TI-2025-28531 An issue was discovered in GoBGP before 3.35.0. CVSS 3.1CRITICAL 9.8
Sources
- CVE-2026-7736 · CVE Program
- CVE-2026-7736 · NVD
- FIRST EPSS
- GHSA-hj4w-qr9j-c4cf · GitHub Advisory Database · CC BY 4.0
- CVE-2026-7736 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences